summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-17 10:13:18 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-17 10:48:28 +0200
commit75c9b32e6a69b08763e90fd826147eb62042e922 (patch)
tree15fce3c56732c9542afd06ca07ae79069c7d5ee3 /dev-ruby/html-pipeline
parentdev-ruby/commonmarker: new package, add 0.23.5 (diff)
downloadgentoo-75c9b32e6a69b08763e90fd826147eb62042e922.tar.gz
gentoo-75c9b32e6a69b08763e90fd826147eb62042e922.tar.bz2
gentoo-75c9b32e6a69b08763e90fd826147eb62042e922.zip
dev-ruby/html-pipeline: new package, add 2.14.2
Closes: https://bugs.gentoo.org/858413 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/html-pipeline')
-rw-r--r--dev-ruby/html-pipeline/Manifest1
-rw-r--r--dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild42
-rw-r--r--dev-ruby/html-pipeline/metadata.xml11
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/html-pipeline/Manifest b/dev-ruby/html-pipeline/Manifest
new file mode 100644
index 000000000000..58c72653effb
--- /dev/null
+++ b/dev-ruby/html-pipeline/Manifest
@@ -0,0 +1 @@
+DIST html-pipeline-2.14.2.tar.gz 39691 BLAKE2B 156b73b1ff2efe9495556b24a5e0b607386ba944e239f3748e9224024d8bcce6f51f54d50db36499a2fbebb083b064f84f62af335576dfafab0554e8e4259204 SHA512 6782295364f9dae304e1044827bd594c742257903f48f78fbcac4359c6596c506bf3028c9d3c33116f1971a568c4aa2de72689c576ab0576ffdda438c6497de6
diff --git a/dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild b/dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild
new file mode 100644
index 000000000000..2f0ed5becc11
--- /dev/null
+++ b/dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="html-pipeline.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GitHub HTML processing filters and utilities"
+HOMEPAGE="https://github.com/gjtorikian/html-pipeline"
+SRC_URI="https://github.com/gjtorikian/html-pipeline/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activesupport-2:*
+ >=dev-ruby/nokogiri-1.4
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/commonmarker
+ dev-ruby/rinku
+ dev-ruby/redcloth
+ dev-ruby/rouge
+ dev-ruby/sanitize
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|focus\)/ s:^:#:' Rakefile test/test_helper.rb || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid running tests for unpackaged optional dependencies
+ # escape_utils, email_reply_parser, gemoji
+ rm -f test/html/pipeline/{email_reply,emoji,plain_text_input,syntax_highlight,toc}_filter_test.rb || die
+}
diff --git a/dev-ruby/html-pipeline/metadata.xml b/dev-ruby/html-pipeline/metadata.xml
new file mode 100644
index 000000000000..53fbb8157b7e
--- /dev/null
+++ b/dev-ruby/html-pipeline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gjtorikian/html-pipeline</remote-id>
+ </upstream>
+</pkgmetadata>