summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/flexmock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/flexmock')
-rw-r--r--dev-ruby/flexmock/Manifest1
-rw-r--r--dev-ruby/flexmock/flexmock-1.3.3-r1.ebuild33
-rw-r--r--dev-ruby/flexmock/flexmock-1.3.3.ebuild33
-rw-r--r--dev-ruby/flexmock/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/flexmock/Manifest b/dev-ruby/flexmock/Manifest
new file mode 100644
index 000000000000..6579f5377097
--- /dev/null
+++ b/dev-ruby/flexmock/Manifest
@@ -0,0 +1 @@
+DIST flexmock-1.3.3.gem 81920 SHA256 1d9cc7dd01b43a25447d85477b8ab096481be0a6536aa6587286082c40f35f9d SHA512 2d440ec5bdbaea0a314f9e40645b194d9e5d29e9dc93c9b38d7fdb256bd4ffb3dba312d7a5630e6d849e360b7f337f6e5e0995a5da6210db2577516a62a66f54 WHIRLPOOL 568005d1238f3927e188cc74756e54512855f146ec729309946837fa2235c0bcf18e05a0bcfd78b938b76fddb239c857bff12a37495fc47d68cf31c25db64c52
diff --git a/dev-ruby/flexmock/flexmock-1.3.3-r1.ebuild b/dev-ruby/flexmock/flexmock-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..9bf4ffd6f535
--- /dev/null
+++ b/dev-ruby/flexmock/flexmock-1.3.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 -> fails specs
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md doc/*.rdoc doc/releases/*"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple mock object library for Ruby unit testing"
+HOMEPAGE="https://github.com/jimweirich/flexmock"
+
+LICENSE="flexmock"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec:2
+ )"
+
+each_ruby_test() {
+ ruby-ng_rspec test/rspec_integration
+ ${RUBY} -S testrb -Ilib:. test/*_test.rb || die
+}
diff --git a/dev-ruby/flexmock/flexmock-1.3.3.ebuild b/dev-ruby/flexmock/flexmock-1.3.3.ebuild
new file mode 100644
index 000000000000..5000b7d09762
--- /dev/null
+++ b/dev-ruby/flexmock/flexmock-1.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 -> fails specs
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md doc/*.rdoc doc/releases/*"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple mock object library for Ruby unit testing"
+HOMEPAGE="https://github.com/jimweirich/flexmock"
+
+LICENSE="flexmock"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec:2
+ )"
+
+each_ruby_test() {
+ ruby-ng_rspec test/rspec_integration
+ ${RUBY} -S testrb -Ilib:. test/*_test.rb || die
+}
diff --git a/dev-ruby/flexmock/metadata.xml b/dev-ruby/flexmock/metadata.xml
new file mode 100644
index 000000000000..f04f476570ae
--- /dev/null
+++ b/dev-ruby/flexmock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jimweirich/flexmock</remote-id>
+ </upstream>
+</pkgmetadata>