summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-07-20 17:10:23 +0200
committerHans de Graaff <graaff@gentoo.org>2020-07-20 17:11:24 +0200
commit6fb7b9cc821e71f28d3a986d5ae54bd3b8b7e392 (patch)
tree8ccd2703987f6a43d155b11b932e5d4964913396 /dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild
parentmedia-libs/jbig2dec: arm stable (bug #719730) (diff)
downloadgentoo-6fb7b9cc821e71f28d3a986d5ae54bd3b8b7e392.tar.gz
gentoo-6fb7b9cc821e71f28d3a986d5ae54bd3b8b7e392.tar.bz2
gentoo-6fb7b9cc821e71f28d3a986d5ae54bd3b8b7e392.zip
dev-ruby/diff-lcs: add 1.4.4
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild')
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild
new file mode 100644
index 000000000000..febdfbd54d42
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( MIT Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid specs failing due to missing fixtures. Should be fixed in the next version.
+ rm -f spec/ldiff_spec.rb || die
+}