summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-07 07:47:16 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-07 08:33:50 +0200
commit494250c5b57edaac62587be5ca6fe4f425eded27 (patch)
treed6766995666ca8d1a8962f25672cd306b78db89f /dev-ruby/childprocess/childprocess-3.0.0.ebuild
parentdev-ruby/charlock_holmes: enable ruby31 (diff)
downloadgentoo-494250c5b57edaac62587be5ca6fe4f425eded27.tar.gz
gentoo-494250c5b57edaac62587be5ca6fe4f425eded27.tar.bz2
gentoo-494250c5b57edaac62587be5ca6fe4f425eded27.zip
dev-ruby/childprocess: drop 3.0.0, 4.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/childprocess/childprocess-3.0.0.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-3.0.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/childprocess/childprocess-3.0.0.ebuild b/dev-ruby/childprocess/childprocess-3.0.0.ebuild
deleted file mode 100644
index 8ab0dffa83b8..000000000000
--- a/dev-ruby/childprocess/childprocess-3.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Solution for controlling external programs running in the background"
-HOMEPAGE="https://github.com/jarib/childprocess"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~s390 sparc x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
- sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:'ruby':'"${RUBY}"':" spec/childprocess_spec.rb || die
-}
-
-each_ruby_test() {
- RUBYLIB=lib RSPEC_VERSION=3 ruby-ng_rspec
-}