summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-11-08 07:58:35 +0100
committerHans de Graaff <graaff@gentoo.org>2023-11-08 08:00:35 +0100
commitd59bd1b60b66ca5c95f97f70ef44c91e4f7e8670 (patch)
tree5526c7ab3eb72afb337f66966d907cb6afdad187 /dev-ruby/cgi/cgi-0.4.0.ebuild
parentdev-ruby/base64: add 0.2.0 (diff)
downloadgentoo-d59bd1b60b66ca5c95f97f70ef44c91e4f7e8670.tar.gz
gentoo-d59bd1b60b66ca5c95f97f70ef44c91e4f7e8670.tar.bz2
gentoo-d59bd1b60b66ca5c95f97f70ef44c91e4f7e8670.zip
dev-ruby/cgi: add 0.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/cgi/cgi-0.4.0.ebuild')
-rw-r--r--dev-ruby/cgi/cgi-0.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/cgi/cgi-0.4.0.ebuild b/dev-ruby/cgi/cgi-0.4.0.ebuild
new file mode 100644
index 000000000000..9087fea27c8e
--- /dev/null
+++ b/dev-ruby/cgi/cgi-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/cgi/escape/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="cgi.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Support for the Common Gateway Interface protocol"
+HOMEPAGE="https://github.com/ruby/cgi"
+SRC_URI="https://github.com/ruby/cgi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e "/spec.version/ s/= version/= '${PV}'/" \
+ -e "/spec.name/ s/= name/= '${PN}'/" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest/lib/helper -e "Dir['test/**/test_*.rb'].each { require _1 }" || die
+}