summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-21 09:06:35 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-21 10:21:11 +0100
commitb74265427018a35c439947b1dc0ac9354eb9f4a4 (patch)
tree6ad769fe33acac7be1c61c1cf20729e105783622 /dev-ros/gazebo_ros
parentdev-ros/gazebo_plugins: Bump to 2.6.2. (diff)
downloadgentoo-b74265427018a35c439947b1dc0ac9354eb9f4a4.tar.gz
gentoo-b74265427018a35c439947b1dc0ac9354eb9f4a4.tar.bz2
gentoo-b74265427018a35c439947b1dc0ac9354eb9f4a4.zip
dev-ros/gazebo_ros: Bump to 2.6.2.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/gazebo_ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest1
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
index 28579f9b6847..134a4b92f74f 100644
--- a/dev-ros/gazebo_ros/Manifest
+++ b/dev-ros/gazebo_ros/Manifest
@@ -1 +1,2 @@
DIST gazebo_ros_pkgs-2.6.1.tar.gz 1825040 SHA256 18b987af9e8e6a59232af8313675bb05f9db39e5c4701459912f996d8c0858b3 SHA512 4cc0b2ec5c60e69b9a69d323c2c7cfe53bc1b5108d6cba5d77b571c69d76a7eb6d72a3783dc60fe183057c63279df8d5cded26cd46333e9f21277e9ae1e31c34 WHIRLPOOL 47510176a89d21144a41aa48e5dfe9bce38fcb5674f1fe157fd4bd0909091cb57eb7ce89e3f39236d5f0960a8a2f1093578de1b9c86626c41e2eccb84e18ec67
+DIST gazebo_ros_pkgs-2.6.2.tar.gz 1830633 SHA256 48f1b1878819a424147195e0b3fa010aaf7b5f7a40ffef522c153f1adc6d3ae0 SHA512 f932eebbc88f4922c0275625d50ad5723446744cbf4a59138437d9bdd75a9b5232fdf8df2012460313eb2224d4287daebc3a28181ab3f1b81e67d70a8b8ed5d3 WHIRLPOOL aa13810a8fbcde4de2c078c89542285cda61f47228bfbe2b237027a920ea5a01ccd823fd1d87d37923202d3a8b88a9017eccc44f1359da32a57cea23489a9948
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild
new file mode 100644
index 000000000000..7cd4e9f2703b
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"