summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-26 16:51:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-26 16:56:12 +0100
commit01957ec3092d768365132cf2ce136afd8df4c0bb (patch)
tree9536b56b9191f34373203aab2077aec8a0b5e531 /dev-ros/ament_uncrustify/ament_uncrustify-0.10.1.ebuild
parentdev-ros/ament_cmake_cpplint: bump to 0.10.1 (diff)
downloadgentoo-01957ec3092d768365132cf2ce136afd8df4c0bb.tar.gz
gentoo-01957ec3092d768365132cf2ce136afd8df4c0bb.tar.bz2
gentoo-01957ec3092d768365132cf2ce136afd8df4c0bb.zip
dev-ros/ament_uncrustify: bump to 0.10.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_uncrustify/ament_uncrustify-0.10.1.ebuild')
-rw-r--r--dev-ros/ament_uncrustify/ament_uncrustify-0.10.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/ament_uncrustify/ament_uncrustify-0.10.1.ebuild b/dev-ros/ament_uncrustify/ament_uncrustify-0.10.1.ebuild
new file mode 100644
index 000000000000..016aff416aad
--- /dev/null
+++ b/dev-ros/ament_uncrustify/ament_uncrustify-0.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check code against style conventions using uncrustify"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-util/uncrustify
+"
+DEPEND=""
+BDEPEND=""