summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-01 03:02:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:10 -0400
commit5c22252b6764bd7e6a608421d9291997d3cdc450 (patch)
treeb55c50379f4a84ab1e86e281d7369e0bd964fd06 /dev-qt/qtscxml
parentdev-qt/qtbase: depend on timezone-data for tests (diff)
downloadgentoo-5c22252b6764bd7e6a608421d9291997d3cdc450.tar.gz
gentoo-5c22252b6764bd7e6a608421d9291997d3cdc450.tar.bz2
gentoo-5c22252b6764bd7e6a608421d9291997d3cdc450.zip
dev-qt/qtscxml: skip flaky test with pid-sandbox (qt6)
clang16+glibc-2.38 -> pass clang16-musl-1.2.4 -> pass clang16[hardened]+glibc-2.38 -> pass gcc13+glibc-2.38 -> pass gcc13[hardened]+glibc-2.38 -> pass gcc12[hardened]+musl-1.2.4 -> fail ??? And then, it passes if FEATURES=-pid-sandbox, so it's at least not broken. Must be hitting some obscure codepath to be stopped by sandbox (or perhaps that chroot ended up with something different that activates something) Have not gotten to the bottom of this, but failing only when using sandbox is all I need to consider skipping it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.2.ebuild6
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.9999.ebuild6
-rw-r--r--dev-qt/qtscxml/qtscxml-6.9999.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/qtscxml-6.5.2.ebuild b/dev-qt/qtscxml/qtscxml-6.5.2.ebuild
index 4c3ca1b8eb07..5e83a6c727eb 100644
--- a/dev-qt/qtscxml/qtscxml-6.5.2.ebuild
+++ b/dev-qt/qtscxml/qtscxml-6.5.2.ebuild
@@ -16,3 +16,9 @@ RDEPEND="
=dev-qt/qtdeclarative-${PV}*:6
"
DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, consider flaky)
+ tst_qstatemachine
+)
diff --git a/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild b/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild
index 4c3ca1b8eb07..5e83a6c727eb 100644
--- a/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild
+++ b/dev-qt/qtscxml/qtscxml-6.5.9999.ebuild
@@ -16,3 +16,9 @@ RDEPEND="
=dev-qt/qtdeclarative-${PV}*:6
"
DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, consider flaky)
+ tst_qstatemachine
+)
diff --git a/dev-qt/qtscxml/qtscxml-6.9999.ebuild b/dev-qt/qtscxml/qtscxml-6.9999.ebuild
index 4c3ca1b8eb07..5e83a6c727eb 100644
--- a/dev-qt/qtscxml/qtscxml-6.9999.ebuild
+++ b/dev-qt/qtscxml/qtscxml-6.9999.ebuild
@@ -16,3 +16,9 @@ RDEPEND="
=dev-qt/qtdeclarative-${PV}*:6
"
DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, consider flaky)
+ tst_qstatemachine
+)