summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-10-08 00:50:45 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-10-08 01:01:18 -0400
commitd75edd00dd8fc2839b0e28e28cd1bf90594115eb (patch)
treeada2a0cde0ffee1e7d94426b3df102bdc19b7ad6 /dev-qt/qtremoteobjects
parentdev-qt/qtquicktimeline: add 6.8.0 (diff)
downloadgentoo-d75edd00dd8fc2839b0e28e28cd1bf90594115eb.tar.gz
gentoo-d75edd00dd8fc2839b0e28e28cd1bf90594115eb.tar.bz2
gentoo-d75edd00dd8fc2839b0e28e28cd1bf90594115eb.zip
dev-qt/qtremoteobjects: add 6.8.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtremoteobjects')
-rw-r--r--dev-qt/qtremoteobjects/Manifest1
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.8.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-qt/qtremoteobjects/Manifest b/dev-qt/qtremoteobjects/Manifest
index 33151965283b..1c1eb19bb518 100644
--- a/dev-qt/qtremoteobjects/Manifest
+++ b/dev-qt/qtremoteobjects/Manifest
@@ -1 +1,2 @@
DIST qtremoteobjects-everywhere-src-6.7.3.tar.xz 537012 BLAKE2B 81363b9ce519dad0ac94109243dffd3043c010d125cb738f1dc49c31b0aa6324a28c055c0126b5992e63b5296781af87f59236c759f3e82121d8cf663d0950e6 SHA512 42b744dc946296bbd57ed31509b720285fd50760484243eede06ac25205fced40060601bef257745635ab4e15a59ddc8bd207dec52246adfde94078706d23e0f
+DIST qtremoteobjects-everywhere-src-6.8.0.tar.xz 537064 BLAKE2B 750f62abb1da3daf5d029c4930054b243b88db0fe6ec738fdce223dae3070c614b946f10f7e6b6e0485cabb8611575df818ecf35ef9b6934797a55691e2784e8 SHA512 5c7899a49daa6ce751394b829d3cf7d12e3cfa74f8fdde6ae9aa74d6346b273901e44700fca5873a957e49b9546ebc964a93fbb8152206723c873ce8139348c6
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.8.0.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.8.0.ebuild
new file mode 100644
index 000000000000..49b703f47ebd
--- /dev/null
+++ b/dev-qt/qtremoteobjects/qtremoteobjects-6.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ qml? (
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( ~dev-qt/qtbase-${PV}:6[gui] )
+"
+
+src_configure() {
+ # same issue as bug #913692 when tests are enabled
+ has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
+ qt6-build_src_test -j1
+}
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ # installs 30+ test binaries like "qt6/bin/state" and, given
+ # otherwise empty, "can" delete the directory rather than list
+ rm -r -- "${D}${QT6_BINDIR}" || die
+ fi
+}