summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-28 03:05:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-28 08:31:19 -0400
commit3bbbaecf8ff805c4c5052373a4332d1795c4cc05 (patch)
treeea9fc6e8d6c8daaa5b6d09fb8091b0f9e93b5f3e /dev-qt/qtmultimedia
parentsys-fs/erofs-utils: keyword 1.7 for ~loong (diff)
downloadgentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.tar.gz
gentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.tar.bz2
gentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.zip
dev-qt/*: drop 6.5.9999
Technically an LTS branch but 6.5.3 is due to be the last "public" release for this branch plus Plasma 6 is based on 6.6, so should have no use for this anymore. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtmultimedia')
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-6.5.9999.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/dev-qt/qtmultimedia/qtmultimedia-6.5.9999.ebuild b/dev-qt/qtmultimedia/qtmultimedia-6.5.9999.ebuild
deleted file mode 100644
index d2ceca20f2b0..000000000000
--- a/dev-qt/qtmultimedia/qtmultimedia-6.5.9999.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic qt6-build
-
-DESCRIPTION="Multimedia (audio, video, radio, camera) library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-IUSE="+X alsa +ffmpeg gstreamer opengl pulseaudio qml v4l vaapi vulkan"
-# tst_qmediaplayerbackend hard requires qml, review in case becomes optional
-REQUIRED_USE="
- || ( ffmpeg gstreamer )
- vaapi? ( ffmpeg )
- test? ( qml )
-"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[gui,network,opengl=,vulkan=,widgets]
- alsa? ( media-libs/alsa-lib )
- ffmpeg? (
- ~dev-qt/qtbase-${PV}:6[X=]
- media-video/ffmpeg:=[vaapi?]
- X? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrandr
- )
- vaapi? ( media-libs/libglvnd )
- )
- gstreamer? (
- dev-libs/glib:2
- media-libs/gst-plugins-bad:1.0
- media-libs/gst-plugins-base:1.0[X=,opengl?]
- media-libs/gstreamer:1.0
- opengl? ( media-libs/libglvnd )
- )
- pulseaudio? ( media-libs/libpulse )
- qml? (
- ~dev-qt/qtdeclarative-${PV}:6
- ~dev-qt/qtquick3d-${PV}:6
- )
-"
-DEPEND="
- ${RDEPEND}
- X? ( x11-base/xorg-proto )
- v4l? ( sys-kernel/linux-headers )
-"
-BDEPEND="~dev-qt/qtshadertools-${PV}:6"
-
-CMAKE_SKIP_TESTS=(
- # tries to use real alsa or pulseaudio and fails in sandbox
- tst_qaudiosink
- tst_qaudiosource
- tst_qmediacapturesession
- tst_qmediaplayerbackend
- tst_qsoundeffect
- # may try to use v4l2 or hardware acceleration depending on availability
- tst_qscreencapture_integration
- tst_qscreencapturebackend
-)
-
-src_configure() {
- # normally passed by the build system, but needed for 32-on-64 chroots
- use x86 && append-cppflags -DPFFFT_SIMD_DISABLE
-
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Qml)
- $(qt_feature alsa)
- $(qt_feature ffmpeg)
- $(qt_feature gstreamer)
- $(usev gstreamer $(qt_feature opengl gstreamer_gl))
- $(qt_feature pulseaudio)
- $(qt_feature v4l linux_v4l)
- $(qt_feature vaapi)
- )
-
- qt6-build_src_configure
-}