summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-29 20:26:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-29 21:50:21 +0100
commit9aee32849455ef3542ae30f627b4615fe6ad21f0 (patch)
tree2a93b94a01f01e013d206fb7d123aa5c7926aeea /dev-qt/qtlocation
parentdev-qt/qtimageformats: 5.15.7 version bump (diff)
downloadgentoo-9aee32849455ef3542ae30f627b4615fe6ad21f0.tar.gz
gentoo-9aee32849455ef3542ae30f627b4615fe6ad21f0.tar.bz2
gentoo-9aee32849455ef3542ae30f627b4615fe6ad21f0.zip
dev-qt/qtlocation: 5.15.7 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest2
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.7.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 795fd26696e6..07328d69f15e 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,2 +1,4 @@
DIST qtlocation-5.15.5-gentoo-kde-1.tar.xz 3952 BLAKE2B ddab14fa3b17d080ea47a6bc10c3ca8fe180ff4954f22833967d1938f06c657c86c2e186e5c6bb50e3fd65c6c0c0b5cc94527bd687b714a315f23dcb7762c606 SHA512 f20b5aea6d68ab6860d69369d58b777ff56de3e2d93e3cbdadd21e6e0fb3511829d5c28b918c19e10290c1e5add0d087f98b2b005ac2f9a5381b9d59fd626a59
+DIST qtlocation-5.15.7-gentoo-kde-1.tar.xz 3948 BLAKE2B fcbac7c87e8c5f470f523c153b6caec2de66ccb7be6f8b0bdbf042d957a88626b4a46848eb6c6442b8199851b908f91241db72f7762816519ef27327f232927d SHA512 396c31cbf3f80c268ebcbf26de8cbfa2d51a355ef4d7824545f7d2fe98ccb5203b61cca9650cfae2793250006b2a5fa514b9bc19fff5650b86ac38a8ba9b9948
DIST qtlocation-everywhere-opensource-src-5.15.5.tar.xz 6559912 BLAKE2B 4f546293b2cfddf5512f3648aef9c527762d6c6ddbaca6583cf0287178524bae9f84e4b94950ce1139042efa995a4f31ef20f26b8d5479048df2ba75cac35d23 SHA512 5090f68926a7bc2f25ea5ae259cb87653b83fcf337c3255a7a2700724f6ac83ec2e1d9b6f38f185ab7dab84e5e042b72c58f4e4cacada6fb7d729378b93d9b3e
+DIST qtlocation-everywhere-opensource-src-5.15.7.tar.xz 6559220 BLAKE2B 635be1ec133a6dd7dbf071922090b6acfe4c02503275ac2539cd4e099dc518ac43654be54e5fa17d292fcdb9edf88a11a1eeec7e37faa752deb6671bef86abba SHA512 fc4579b14f7f4836ef550d80b867c2655f52da34b0637dce4d83b10f2f7a836530a8f2a6b0f1a41c38e5e391c5d8e2431818e9813fd9d597f67704fcfbfb2f7e
diff --git a/dev-qt/qtlocation/qtlocation-5.15.7.ebuild b/dev-qt/qtlocation/qtlocation-5.15.7.ebuild
new file mode 100644
index 000000000000..ebcbd1ab6c03
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}