summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-16 07:32:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-16 08:01:58 +0100
commitf54fa9a42db3343a0c3d80dd39d5ea8265636690 (patch)
treedf79931a5b8ae547413f0767f56d67c4580b96de /dev-python
parentdev-python/hypothesis: Bump to 6.93.2 (diff)
downloadgentoo-f54fa9a42db3343a0c3d80dd39d5ea8265636690.tar.gz
gentoo-f54fa9a42db3343a0c3d80dd39d5ea8265636690.tar.bz2
gentoo-f54fa9a42db3343a0c3d80dd39d5ea8265636690.zip
dev-python/plyvel: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/plyvel/Manifest1
-rw-r--r--dev-python/plyvel/plyvel-1.5.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/plyvel/Manifest b/dev-python/plyvel/Manifest
index ef0151223512..be0a76d9ce39 100644
--- a/dev-python/plyvel/Manifest
+++ b/dev-python/plyvel/Manifest
@@ -1 +1,2 @@
DIST plyvel-1.5.0.tar.gz 152348 BLAKE2B eca4780ecce793d514647557b13cb134a10c6bc46b981e6f92caa01715180a95c511fee1e75eee677778c34084058fba029547557442b86a0286a0d959dd550d SHA512 3f12b1d17a7b4b52fc2874b091a7378f3e8c0f895a3993f86ce6a686f7f94d28b585c5e6aa9b48ebb7d9106cae2b148aa15a87f07dfb232a0678ed151d8e09c1
+DIST plyvel-1.5.1.tar.gz 200128 BLAKE2B d9fec1af0542a93ca25247abd7e17a9f868de2878d6dcbb846cad3326057d36b52ff0b85bfd342f0ed447ebf9925584b6fb95a47b6d424bb9b24f9aa35fa30c1 SHA512 8f613197e85d085ea47e5a5d6b2bf0310f52fb51eeda6ed7f8cb559c192583f3cb25b66227876c01a08f6a355aafd5092673b7d5341b9b6e5d24546b7755d275
diff --git a/dev-python/plyvel/plyvel-1.5.1.ebuild b/dev-python/plyvel/plyvel-1.5.1.ebuild
new file mode 100644
index 000000000000..fb7c8b655e5a
--- /dev/null
+++ b/dev-python/plyvel/plyvel-1.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+# Disable PyPy3 for now because it is not stable enough:
+# https://github.com/wbolster/plyvel/issues/140
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to LevelDB"
+HOMEPAGE="
+ https://github.com/wbolster/plyvel/
+ https://pypi.org/project/plyvel/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/leveldb-1.21:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+src_configure() {
+ emake cython
+}
+
+python_test() {
+ rm -rf plyvel || die
+ epytest
+}