summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 22:43:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:36 -0500
commiteacd79ba361cd24dc93b90db66a1ccdcf4a65c9f (patch)
tree4ca0038bc930e9bf46672b6d7b3a30ebfe235f86 /dev-python
parentdev-python/lmdb: add py37 support (diff)
downloadgentoo-eacd79ba361cd24dc93b90db66a1ccdcf4a65c9f.tar.gz
gentoo-eacd79ba361cd24dc93b90db66a1ccdcf4a65c9f.tar.bz2
gentoo-eacd79ba361cd24dc93b90db66a1ccdcf4a65c9f.zip
dev-python/zict: 0.1.3 add py37 support
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zict/zict-0.1.3.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/zict/zict-0.1.3.ebuild b/dev-python/zict/zict-0.1.3.ebuild
index 7879fdb202c9..830b4d724056 100644
--- a/dev-python/zict/zict-0.1.3.ebuild
+++ b/dev-python/zict/zict-0.1.3.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
@@ -20,9 +19,9 @@ RDEPEND="dev-python/HeapDict[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/HeapDict[${PYTHON_USEDEP}]
- dev-python/lmdb[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/HeapDict[${PYTHON_USEDEP}]
+ dev-python/lmdb[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {