summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-18 07:45:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-18 08:04:29 +0200
commitdb2c30ca9faa91a8e30600936a11a3e4590171ee (patch)
tree56bdfecdad8ff526e0d144a5301a345d15ea395c /dev-python
parentdev-python/sqlglot: Bump to 25.13.0 (diff)
downloadgentoo-db2c30ca9faa91a8e30600936a11a3e4590171ee.tar.gz
gentoo-db2c30ca9faa91a8e30600936a11a3e4590171ee.tar.bz2
gentoo-db2c30ca9faa91a8e30600936a11a3e4590171ee.zip
dev-python/automat: Bump to 24.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/automat/Manifest1
-rw-r--r--dev-python/automat/automat-24.8.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/automat/Manifest b/dev-python/automat/Manifest
index a4cba4eb2f17..67a71d3d4c1e 100644
--- a/dev-python/automat/Manifest
+++ b/dev-python/automat/Manifest
@@ -1 +1,2 @@
DIST Automat-22.10.0.tar.gz 59099 BLAKE2B 509e64b1312f87f09a60243a00b832c8b3da4b09ef75151e82c8c406faabd24a56378baade87bd98685fa22922d1892ec20d81579eaf13e0315af68bb7909ac4 SHA512 5819cfe0687bf391949891562f3657f449cf9a8e8ea90c1537e89509dc618da1160856f92ab52dc450e0a7d51d0e4644bfe2db3d4108126a42ee1bea2f06bb7a
+DIST automat-24.8.0.tar.gz 128649 BLAKE2B 99ac2470cde44237dc4a0efee0bc962e5b2cd8a8caa9082e75d5a89799da8b39320e08e714a1a1e538468eb1366d426aa55503168385a78ead18aedd6233bafb SHA512 8cc93d3783a23e716aef099c359ecbf7f4feb34e875752a74cd8dfed410412ddffaa84d1939672a8605b6f77925402c6e518c04c6029dc6f0b33fa925fdda0b7
diff --git a/dev-python/automat/automat-24.8.0.ebuild b/dev-python/automat/automat-24.8.0.ebuild
new file mode 100644
index 000000000000..609c8cc0eae3
--- /dev/null
+++ b/dev-python/automat/automat-24.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Self-service finite-state machines for the programmer on the go"
+HOMEPAGE="
+ https://github.com/glyph/automat/
+ https://pypi.org/project/Automat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ benchmark
+)
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc docs/examples/*.py
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo "For additional visualization functionality install both these optional dependencies"
+ einfo " >=dev-python/twisted-16.1.1"
+ einfo " media-gfx/graphviz[python]"
+}