summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-07 20:35:08 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-07 22:38:16 +0100
commitc24174740bb99b03d91d97d39cbdfaa02294830d (patch)
tree13db37bdf5b99d84b63e3a17e4ea88fbdcb3d080 /dev-python
parentdev-libs/openssl: drop 1.1.1s-r2 (diff)
downloadgentoo-c24174740bb99b03d91d97d39cbdfaa02294830d.tar.gz
gentoo-c24174740bb99b03d91d97d39cbdfaa02294830d.tar.bz2
gentoo-c24174740bb99b03d91d97d39cbdfaa02294830d.zip
dev-python/jupyterlab_server: add 2.19.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyterlab_server/Manifest1
-rw-r--r--dev-python/jupyterlab_server/jupyterlab_server-2.19.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/jupyterlab_server/Manifest b/dev-python/jupyterlab_server/Manifest
index 3bc058a8cf61..89871ff93cfe 100644
--- a/dev-python/jupyterlab_server/Manifest
+++ b/dev-python/jupyterlab_server/Manifest
@@ -1 +1,2 @@
DIST jupyterlab_server-2.16.5.tar.gz 67949 BLAKE2B 0e2e1ad3ca9163d34762893b3af2e675a8474fdb129e8735e567f111549ecaf1c23693064b757d68aeec63469f071428d827e361b253bcf241474f5386934bba SHA512 b125c3283d42ea813b12f891144665ec5c4a5827cbb01e9f80cd7826ba2647016344f939807c7095021293eb01e5ec3e151ce206272d0dca3eba3d7423fc4a6b
+DIST jupyterlab_server-2.19.0.tar.gz 69979 BLAKE2B f44eea3aa2a19c0f2e548b33e1677a8daf4b6098bfb682f3ebae816d38c6cd24769aea35053f2a9e656e5b2bba2a032d4bd75ba976d30238fa4d27c9a1a69867 SHA512 058a1663ca1d6663be9de1243b178637a61e2ff156ca00163d9f30301d8527ca26235f1d3183bc2b48b6b4b82dbea595a4c7f0a989736b603851f5d78f8da078
diff --git a/dev-python/jupyterlab_server/jupyterlab_server-2.19.0.ebuild b/dev-python/jupyterlab_server/jupyterlab_server-2.19.0.ebuild
new file mode 100644
index 000000000000..b7d2f27245bd
--- /dev/null
+++ b/dev-python/jupyterlab_server/jupyterlab_server-2.19.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter_server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst_parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}