summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 09:11:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 11:14:25 +0200
commitc0113b9e2799b3f7ffe631ac35e859630a75ca8c (patch)
treee7770c545bf5d74d3df46085f6b68625d49c889f /dev-python
parentdev-python/moto: Bump to 3.1.12 (diff)
downloadgentoo-c0113b9e2799b3f7ffe631ac35e859630a75ca8c.tar.gz
gentoo-c0113b9e2799b3f7ffe631ac35e859630a75ca8c.tar.bz2
gentoo-c0113b9e2799b3f7ffe631ac35e859630a75ca8c.zip
dev-python/cx_Freeze: Bump to 6.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.11.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index 207f62f1dda6..c87659fe2306 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -1 +1,2 @@
+DIST cx_Freeze-6.11.0.gh.tar.gz 1307157 BLAKE2B 6897dcec37f606cf5440e8bc849dfc5c20f4cbd79099da973f855d99d8cc59845da526c36d3918dc85e5c2b279b089468c07cd7f3849b452f109205d9d4e4fc3 SHA512 f10556c9ca1222fcc4fc4a31588a57788067dc16c5ac365503e95e2df0729ae045b7b1ac6416736e9193759a054545e3966dac54136991094183dd0b93b2f47a
DIST cx_Freeze-6.9.gh.tar.gz 1273371 BLAKE2B d005fdf0e2ac49cb4f347256d3b643124694a0628e4abf6806c122c144bb973e14a2d9101b2d446394d50c6c0d9af7edca1e62b50bb4d76f63c96fabfda6cc7c SHA512 219f052cae05a757c2cd57c45e47c0b3e85662ace895a8b768e1571044e132b7db367af2a6293d175e022f79f87b02007dfdd8807eb39be04a89602b51cc0246
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.11.0.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.11.0.ebuild
new file mode 100644
index 000000000000..81d66f5e8a4c
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.11.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="https://cx-freeze.readthedocs.io/"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ virtual/libcrypt:=
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # new setuptools?
+ tests/test_bdist_rpm.py::test_bdist_rpm
+)