summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:42:42 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:00 +0100
commit8e3578ecc64010c400d42920ed9dccc7ee00a6b8 (patch)
treefa9938b14ae1b0e54e3300779997ef078e1cbdbf /dev-python
parentdev-python/pyspectrum2: drop 0.2.0 (diff)
downloadgentoo-8e3578ecc64010c400d42920ed9dccc7ee00a6b8.tar.gz
gentoo-8e3578ecc64010c400d42920ed9dccc7ee00a6b8.tar.bz2
gentoo-8e3578ecc64010c400d42920ed9dccc7ee00a6b8.zip
dev-python/python-axolotl: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-axolotl/python-axolotl-0.2.3-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-axolotl/python-axolotl-0.2.3-r2.ebuild b/dev-python/python-axolotl/python-axolotl-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..623c67cb0b94
--- /dev/null
+++ b/dev-python/python-axolotl/python-axolotl-0.2.3-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for the axolotl protocol"
+HOMEPAGE="https://github.com/tgalal/python-axolotl"
+SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-axolotl-curve25519[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest