summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-20 14:12:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-20 15:02:25 +0200
commit86f90e566b5f6177b1ab5ef0987d6c225c3e5250 (patch)
treeaf80aab74d68d8afdf6e6fce9ad958405008909d /dev-python
parentnet-print/cups: Drop obsolete IUSE=lprng-compat (diff)
downloadgentoo-86f90e566b5f6177b1ab5ef0987d6c225c3e5250.tar.gz
gentoo-86f90e566b5f6177b1ab5ef0987d6c225c3e5250.tar.bz2
gentoo-86f90e566b5f6177b1ab5ef0987d6c225c3e5250.zip
dev-python/asttokens: Bump to 2.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/asttokens/Manifest1
-rw-r--r--dev-python/asttokens/asttokens-2.0.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index 4ba74c49802e..25a698734cf6 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1 +1,2 @@
DIST asttokens-2.0.4.gh.tar.gz 46823 BLAKE2B 111ed58c1b657900f830b7b9f521c1f87fd37945ab6ed6e165108fc2371923030b37cae33885e166a524eb8dd5cfad5fe9391a19b7729b7cd504474d1477748d SHA512 49287259d64c43c7460357d19ed95495ab499b0ad7ae0d5a59378ea0332142b574643349d1d3ca56442712ebec14c53167da475915017feb1b524ac190f9dac3
+DIST asttokens-2.0.5.gh.tar.gz 46876 BLAKE2B 8a8da138888de0a4096b10eccc483c9540710acde0da188ed3fb3845f96b862fe2eec393c69ca62e7b313bfa0e2f0d673d828e9d1ff6dbbf5b641fe8122a548d SHA512 3e710ca9703e67643bb9c0a4db4e5c1656e6d5c904a1262a9ddb962beff06e4e8bd9815bcd2509b48974a97a565d8479a4369583c166a65b6d16c19fd926e93f
diff --git a/dev-python/asttokens/asttokens-2.0.5.ebuild b/dev-python/asttokens/asttokens-2.0.5.ebuild
new file mode 100644
index 000000000000..d1c976711b1e
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}