summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-12-18 02:25:12 -0500
committerMichał Górny <mgorny@gentoo.org>2023-12-21 04:27:28 +0100
commit8560f90b6217d20450db6d12841f924df086ee42 (patch)
treec936f57e338644b482c9108beb724641a0bc953c /dev-python
parentdev-python/pypy3_10: fixup compileall call excludes (diff)
downloadgentoo-8560f90b6217d20450db6d12841f924df086ee42.tar.gz
gentoo-8560f90b6217d20450db6d12841f924df086ee42.tar.bz2
gentoo-8560f90b6217d20450db6d12841f924df086ee42.zip
dev-python/pypy: inline python_optimize, restrict to valid files
There's a bunch of testdata that isn't supposed to be compiled. The CPython build system automatically excludes it, but PyPy doesn't have a build system so we must do it manually. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34349 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy/pypy-7.3.13.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pypy/pypy-7.3.13.ebuild b/dev-python/pypy/pypy-7.3.13.ebuild
index cefd623b2968..3b82197f2e0a 100644
--- a/dev-python/pypy/pypy-7.3.13.ebuild
+++ b/dev-python/pypy/pypy-7.3.13.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit pax-utils python-utils-r1
+inherit pax-utils
PYPY_PV=${PV%_p*}
MY_P=pypy2.7-v${PYPY_PV/_}
@@ -288,13 +288,14 @@ src_install() {
dosym ../lib/pypy2.7/pypy-c /usr/bin/pypy
dodoc README.rst
- local -x EPYTHON=pypy
local -x PYTHON=${ED}${dest}/pypy-c-${PYPY_PV}
# temporarily copy to build tree to facilitate module builds
cp -p "${BROOT}${dest}/pypy-c-${PYPY_PV}" "${PYTHON}" || die
einfo "Byte-compiling Python standard library..."
- python_optimize "${ED}${dest}"
+ "${PYTHON}" -m compileall \
+ -x 'bad_coding|badsyntax|make_ssl_data|lib2to3/tests/data' \
+ -q -f -d "${dest}" "${ED}/${dest}" || die
# remove to avoid collisions
rm "${PYTHON}" || die