summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-25 03:43:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-25 04:02:30 +0200
commit7c19adf80a88e9173cdb42d358fdb639d5546cf0 (patch)
treefdfa07400f06a3fdc85344e15dc3985da20677e7 /dev-python
parentdev-python/pyproject-fmt: Bump to 0.10.0 (diff)
downloadgentoo-7c19adf80a88e9173cdb42d358fdb639d5546cf0.tar.gz
gentoo-7c19adf80a88e9173cdb42d358fdb639d5546cf0.tar.bz2
gentoo-7c19adf80a88e9173cdb42d358fdb639d5546cf0.zip
dev-python/Faker: Bump to 18.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Faker/Faker-18.5.1.ebuild34
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-18.5.1.ebuild b/dev-python/Faker/Faker-18.5.1.ebuild
new file mode 100644
index 000000000000..f1e5f5fe409a
--- /dev/null
+++ b/dev-python/Faker/Faker-18.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index c66666447201..f97beaa574df 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-18.4.0.tar.gz 1664014 BLAKE2B daf3ea7f05bdaab27a70d72b26042a0a205963d56848b97d45ad8a4e04dfbbffecc1ffb94dc0570fca7ea339df9e28a6cde85b879589f4619eccddd71fc5b686 SHA512 a0c0d1b5eb087dfe160248c4ecc0fe7ea037aad715f62621f9d4764cadc684741db025b39af511b38577818f9087ba11950962f618dfd18d08f30b18d89b1b56
+DIST Faker-18.5.1.tar.gz 1664745 BLAKE2B c6b02b9827a0cda7ac37bdc12882e879b8b981b6fcf734fa887a36cef62bf7605c8d66158efc673ecc937b907370002f1f3b3a35f33daf24c4a13cbbb6061ca7 SHA512 735343cfd081f1328f4ce5eddd22d226a9a01529d6e9975d1cc23a54ce0e9786903daa59ab3aaa1575fd8869406c709c7b51a5f364a7b3010e11473cb477be45