summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 17:33:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 18:17:00 +0200
commit7465b3d23591229eec597724bd48c948ef08c187 (patch)
tree5d4d5b6e6a8fc00ad60211bed18b538f4e45be96 /dev-python
parentdev-python/service_identity: Enable py3.11 (diff)
downloadgentoo-7465b3d23591229eec597724bd48c948ef08c187.tar.gz
gentoo-7465b3d23591229eec597724bd48c948ef08c187.tar.bz2
gentoo-7465b3d23591229eec597724bd48c948ef08c187.zip
dev-python/priority: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/priority/priority-1.3.0-r1.ebuild31
-rw-r--r--dev-python/priority/priority-2.0.0-r1.ebuild6
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/priority/priority-1.3.0-r1.ebuild b/dev-python/priority/priority-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..0ac83b220d50
--- /dev/null
+++ b/dev-python/priority/priority-1.3.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
+HOMEPAGE="
+ https://python-hyper.org/projects/priority/en/latest/
+ https://github.com/python-hyper/priority/
+ https://pypi.org/project/priority/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/priority-1.3.0-test-timeout.patch
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/priority/priority-2.0.0-r1.ebuild b/dev-python/priority/priority-2.0.0-r1.ebuild
index e18fa7a80fef..58b0eaf3001e 100644
--- a/dev-python/priority/priority-2.0.0-r1.ebuild
+++ b/dev-python/priority/priority-2.0.0-r1.ebuild
@@ -9,9 +9,11 @@ PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
-HOMEPAGE="https://python-hyper.org/projects/priority/en/latest/
+HOMEPAGE="
+ https://python-hyper.org/projects/priority/en/latest/
https://github.com/python-hyper/priority/
- https://pypi.org/project/priority/"
+ https://pypi.org/project/priority/
+"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"