summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-16 11:38:53 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-16 12:31:42 +0100
commit5b1e11cef49b1b3299aaeaa33dee1643d3293fd6 (patch)
treee21f257b03e824ae155104ab225c91f82544ab9f /dev-python
parentdev-python/nuitka: Remove old (diff)
downloadgentoo-5b1e11cef49b1b3299aaeaa33dee1643d3293fd6.tar.gz
gentoo-5b1e11cef49b1b3299aaeaa33dee1643d3293fd6.tar.bz2
gentoo-5b1e11cef49b1b3299aaeaa33dee1643d3293fd6.zip
dev-python/nuitka: Bump to 1.2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.2.7.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 9ad787b00e9d..e7f1b2b16b27 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-1.2.6.tar.gz 3959091 BLAKE2B b326409f49d722bcac7df3e2c5caae7fb9ccf2b2991d2cf003a4db7bd268af95b7423da3b69b93b45c2aa1e3461faac90872b01f2d2277c5e9f7c71bedb0df56 SHA512 b12f694f8ac26213fd1242c66c2a37be1940bafef8a4949f0e401f056a1f72a010d1df237a828317ed0c88530206c31e617f03e4bccf6c934b967f8ddaef330f
+DIST Nuitka-1.2.7.tar.gz 3960368 BLAKE2B 582ad7f7a96577fd87a4f9fe083d90f532f2ddd7824b4105d258551b559d9390fba428b80223c6ca4d00eda451cc21a63449c7370a3e43d4b7f9a28fc6bba4c9 SHA512 37a3c29614102dc80f916ac483a6e87322b7a3b9cf25355bdf2f29d84e33300640607fcb7fdc6a338431bc890b4337512c43368e47a2d69c7254b7b7794bb35b
diff --git a/dev-python/nuitka/nuitka-1.2.7.ebuild b/dev-python/nuitka/nuitka-1.2.7.ebuild
new file mode 100644
index 000000000000..b55f0385d58a
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.2.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}