summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-08-17 09:21:29 -0500
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-08-17 16:44:35 +0200
commit4d1d228b10e2c1b1a587bd8eb81e7f260e06b0b8 (patch)
treead1aad35f2b3473a8facfb55c4a60ffc680bf951 /dev-python
parentdev-util/azuredatastudio: bump to 1.49.1 (diff)
downloadgentoo-4d1d228b10e2c1b1a587bd8eb81e7f260e06b0b8.tar.gz
gentoo-4d1d228b10e2c1b1a587bd8eb81e7f260e06b0b8.tar.bz2
gentoo-4d1d228b10e2c1b1a587bd8eb81e7f260e06b0b8.zip
dev-python/pycpio: Add 1.3.1 and tests
Signed-off-by: Zen <z@pyl.onl> Closes: https://github.com/gentoo/gentoo/pull/38179 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycpio/Manifest1
-rw-r--r--dev-python/pycpio/pycpio-1.3.1.ebuild24
-rw-r--r--dev-python/pycpio/pycpio-9999.ebuild6
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pycpio/Manifest b/dev-python/pycpio/Manifest
index 81df698a05fd..d8ddc058cbca 100644
--- a/dev-python/pycpio/Manifest
+++ b/dev-python/pycpio/Manifest
@@ -1 +1,2 @@
DIST pycpio-1.2.1.tar.gz 18512 BLAKE2B e835e3810d174d8f4cd5afc2984c0d84d55f9492725c16afdcd1b760dc8c58b4b83a1d13c0b266c8ec9407ab5c1114fe95468d742b202ba99e3c4a76a69dff15 SHA512 4611829339a45a848deb0c5c35098215ac7c378714e4fb1e10975e00b386e5e6bcd295fde83f361998f234f506276b906a4424a7d4aa925fe2bd92a0d7311d86
+DIST pycpio-1.3.1.tar.gz 22457 BLAKE2B de24a569d7114e31e9093d05f7b3651e9ee1e77c233d46114bd53e0821b1c7bbaac61691dd8abfb0ade23bdc15c8e5f35f2c8c7cb8e1160b82450dcc7e8280bc SHA512 5672ed515434e94c4812532d4405db172eaa54ed9ef497b31fe354eb374157b070ab50481cc852e04312d01aa821fe0c4aeb2824cfc246c68c841288a92a25d9
diff --git a/dev-python/pycpio/pycpio-1.3.1.ebuild b/dev-python/pycpio/pycpio-1.3.1.ebuild
new file mode 100644
index 000000000000..837c98d10d5d
--- /dev/null
+++ b/dev-python/pycpio/pycpio-1.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND=">=dev-python/zenlib-2.1.2[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests/
+}
diff --git a/dev-python/pycpio/pycpio-9999.ebuild b/dev-python/pycpio/pycpio-9999.ebuild
index a025a3b5791e..140af15820ae 100644
--- a/dev-python/pycpio/pycpio-9999.ebuild
+++ b/dev-python/pycpio/pycpio-9999.ebuild
@@ -15,3 +15,9 @@ LICENSE="GPL-2"
SLOT="0"
RDEPEND=">=dev-python/zenlib-9999[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests/
+}