summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 06:47:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 06:58:09 +0100
commit38754e58f23770c707eb50da58e1f199cf237bd6 (patch)
tree06d62ecec6eff05352374e773bc3201d5ed31f20 /dev-python
parentdev-python/owslib: Bump to 0.29.3 (diff)
downloadgentoo-38754e58f23770c707eb50da58e1f199cf237bd6.tar.gz
gentoo-38754e58f23770c707eb50da58e1f199cf237bd6.tar.bz2
gentoo-38754e58f23770c707eb50da58e1f199cf237bd6.zip
dev-python/precis-i18n: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/precis-i18n/Manifest1
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/Manifest b/dev-python/precis-i18n/Manifest
index 791b30b477cf..dd1384c3588c 100644
--- a/dev-python/precis-i18n/Manifest
+++ b/dev-python/precis-i18n/Manifest
@@ -1 +1,2 @@
DIST precis_i18n-1.0.5.tar.gz 67710 BLAKE2B 7995c3cb74290524d70ecd75b052201df49ae7e9f4d0052c8176756866ba8533d164b057f0fc4c5c47b938a20e36898cb52bec411b56461cb9c4e4f7029db4ed SHA512 ba3b43d4a84de02e002f7e62a7fb75c4694f3c6a8963e5bdfd9927989c2ee84317fc5fa6f119e79bb1f88dc97a37a06930829daae3969d6a5b2f5ba57bedc3e9
+DIST precis_i18n-1.1.0.tar.gz 69488 BLAKE2B 2484e8b9d8df7393b1e61030da45ff22a864cb4d97c0e1b1bff319035810ef65f3686510c16335be678c32503333e667fa4555365976ace2a93ae80a532ede86 SHA512 95eb40aa063a808885e9a405f8331621e74b669d4602de617f0e6e78e4d9b7f57665d194b826bbdfc6305c71eaecd2e6388f79b2381d85abc606fe7515510b45
diff --git a/dev-python/precis-i18n/precis-i18n-1.1.0.ebuild b/dev-python/precis-i18n/precis-i18n-1.1.0.ebuild
new file mode 100644
index 000000000000..ba09e54a5f5c
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="
+ https://github.com/byllyfish/precis_i18n/
+ https://pypi.org/project/precis-i18n/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}