summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-18 08:58:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-18 09:05:50 +0200
commit37bad3b8064d7db770acbb46d5cb46c9fa6b2bd5 (patch)
tree67681076749f0f148bb5fc55806864aed8436db2 /dev-python
parentsci-physics/lammps: Remove old (diff)
downloadgentoo-37bad3b8064d7db770acbb46d5cb46c9fa6b2bd5.tar.gz
gentoo-37bad3b8064d7db770acbb46d5cb46c9fa6b2bd5.tar.bz2
gentoo-37bad3b8064d7db770acbb46d5cb46c9fa6b2bd5.zip
dev-python/pyopencl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2020.3.1.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index c0dbc7aa13b8..5d7a2e38fb34 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1 @@
-DIST pyopencl-2020.3.1.tar.gz 357422 BLAKE2B de9cb6408e957e30f54797ce682ed17f3272dc82019bcd9a744a0696a7e344f47645a3549332da90e0bcc442f7a8ea9c6a12a375875a9728fa9814ca9d1a9b30 SHA512 459d6f060f4203e83276c47bf832f33fc4348dd59904ea55fe2a53684cb7c8eaad45875476d10dcb6653820f9cb1f7e013c6b854410b2040b2dfe847fc1f7658
DIST pyopencl-2021.1.3.tar.gz 447070 BLAKE2B fcd8c5d06de9c14a7bcf3c3d37f89cb208adf0225cc88a081aefc86aac82a99026183f2c9975f34cd8247f784335e4ba6c0a09164ce01e527123b5c1dd952a76 SHA512 8799e73b3b1596387f619fd997f643228679fb1d9ab5ce6704da9df51922f96229efc98ab6b7a7361234848078b15bc67946a4188f4d17cb8760040b48b346e8
diff --git a/dev-python/pyopencl/pyopencl-2020.3.1.ebuild b/dev-python/pyopencl/pyopencl-2020.3.1.ebuild
deleted file mode 100644
index 2c8ad069433b..000000000000
--- a/dev-python/pyopencl/pyopencl-2020.3.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples opengl"
-
-COMMON="dev-python/numpy[${PYTHON_USEDEP}]"
-RDEPEND="${COMMON}
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=virtual/opencl-2"
-DEPEND="${COMMON}
- dev-python/pybind11[${PYTHON_USEDEP}]"
-
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}