summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-04 04:31:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-04 04:41:59 +0200
commit2859cab4d525513f6580f0bbc48f43b33f82568c (patch)
tree7d617c8475335b7042d7b39172a14912320d9a9a /dev-python
parentdev-python/openstacksdk: Bump to 1.4.0 (diff)
downloadgentoo-2859cab4d525513f6580f0bbc48f43b33f82568c.tar.gz
gentoo-2859cab4d525513f6580f0bbc48f43b33f82568c.tar.bz2
gentoo-2859cab4d525513f6580f0bbc48f43b33f82568c.zip
dev-python/PyGithub: Bump to 1.59.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.59.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index e8926224b30e..ec5db36c8169 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1 +1,2 @@
DIST PyGithub-1.59.0.tar.gz 3295401 BLAKE2B 39261ddcd20112aa529c17f66c8e69d7af7db9708f179395f29ea4b881fdec4598637b63ca1214affc2f6a9c15db227e57ade51029ed578a6b90633d353712cf SHA512 2a95fb9a99c096a1ee0971df133338764275a9ac99e58a4d81ece954831497e0aaf6eec26172513843098777666ab4f3c5df92a42802f0b953fe50f5ec7824a9
+DIST PyGithub-1.59.1.tar.gz 3295328 BLAKE2B 7a7dcfa49261aa7c6d7d3b252c77cc93bd24440858989ef2a8b257235ed7b101647c08532860f0fa21d1b8f2ac35541341df49a94c3495c7d9666fe7367738c1 SHA512 795c104253b250b11b539b526944776f70e947e23dc4b26fcdadb5de3dd3208a9b27c08ffdd14cade220fde3360b6993be7a028f0069ff60d99331048560faed
diff --git a/dev-python/PyGithub/PyGithub-1.59.1.ebuild b/dev-python/PyGithub/PyGithub-1.59.1.ebuild
new file mode 100644
index 000000000000..c22ebb71ed44
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.59.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="
+ https://github.com/PyGithub/PyGithub/
+ https://pypi.org/project/PyGithub/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# cryptography via pyjwt[crypto]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest