summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-12-08 20:22:18 -0500
committerTim Harder <radhermit@gentoo.org>2017-12-08 20:23:00 -0500
commit2427abd3ef8dda61749a615949cb9afdd37e2ca9 (patch)
tree2b795ba089fa5269d06b6235a2b848d4bbf81b7b /dev-python
parentdev-python/cryptography-vectors: version bump to 2.1.4 (diff)
downloadgentoo-2427abd3ef8dda61749a615949cb9afdd37e2ca9.tar.gz
gentoo-2427abd3ef8dda61749a615949cb9afdd37e2ca9.tar.bz2
gentoo-2427abd3ef8dda61749a615949cb9afdd37e2ca9.zip
dev-python/cryptography: version bump to 2.1.4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-2.1.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index 4acab4c91e6a..828579118129 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -7,3 +7,4 @@ DIST cryptography-2.0.3.tar.gz 427544 SHA256 d04bb2425086c3fe86f7bc48915290b13e7
DIST cryptography-2.1.1.tar.gz 441477 SHA256 2699ed21e1f73dd1bdb7b0b22a517295de07809d535b23e200dd22166037fe6f SHA512 d021f7af1cb4c6430049d2213405b7bea84bc0bde9e9f92c99c87dd835b2f28eb28024d65090756d2cc72b63510f25d71c55e473ce00e1d24736c15037998adb WHIRLPOOL 1095cc8698775904019744bb7c7410f405183fa4b497f2a1a66bb3922176e2dacab3c050eb9d081fa0bf07aed268782950e9953d10582e4d57e953d30d93618c
DIST cryptography-2.1.2.tar.gz 441439 SHA256 d7f348e4f5df146a0e75998544bab6d42313cf19a81a6e49990ab7b27cc9c73b SHA512 a5a1bf7ea60f172ae72816965a471be00ee092151c02d9d792579a4457cceddd181d5d95fb832752981f9bdd3cfb88a5d531562845b0b70f37b39fb0fbcafe85 WHIRLPOOL 49c543b80c09f77daf2a49a784bb2132dfadf07dde5b1f7e5c9174b215dda7113ab8b90a5cac386010bcc5fe0c012f55b601b895087f4c0bcbb126b8435cf440
DIST cryptography-2.1.3.tar.gz 441502 SHA256 68a26c353627163d74ee769d4749f2ee243866e9dac43c93bb33ebd8fbed1199 SHA512 04b340550955ab177e3ca3b63ad39f903cee8ae12d3dee1039507e09b9257210ea4474265cb521b8f93a5ccda8dd829640ed04bc16bb7e3663651e64a5bbe8e3 WHIRLPOOL 16fdd77eb60bd46331add278e8cd15a8a8f2d45c482d671997c1dac1835db39aba4812c21df9a0203a62b2cebc6c130c57a6760e0167a7dbaa1518d427087045
+DIST cryptography-2.1.4.tar.gz 441557 BLAKE2B 66aa07930ee54469328977e27096e65b7a333b38b71828c71cb7891b489ef7af60f5e5590f67b43d5e63dc2279d9ca1ba036879f3145264f7639d65000958b50 SHA512 f749cb4384badc174a842514e5a4fee2ed01ab9c716799d8d9d5301f6d2d97b6c41deb9e425f48928b639fa34bef8c05529ed7e5b777ef5ca75c244f8fda8fd4
diff --git a/dev-python/cryptography/cryptography-2.1.4.ebuild b/dev-python/cryptography/cryptography-2.1.4.ebuild
new file mode 100644
index 000000000000..ab61cfd83112
--- /dev/null
+++ b/dev-python/cryptography/cryptography-2.1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x64-solaris"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= ( || ( dev-libs/openssl:0[-bindist(-)]
+ =dev-libs/openssl-1.0.2l-r1:0
+ >=dev-libs/openssl-1.1.0g-r1:0 ) ) )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_configure_all() {
+ append-cflags $(test-flags-CC -pthread)
+}
+
+python_test() {
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}