summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-10-28 20:26:23 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-10-28 20:26:23 +0700
commit0e5b0846d0214e4c0045ec72ac9b5869e70164bc (patch)
treee4330f3fe4537040be1318a14e1319b1f7c44ee3 /dev-python
parentdev-python/pycson: add python3_12 (diff)
downloadgentoo-0e5b0846d0214e4c0045ec72ac9b5869e70164bc.tar.gz
gentoo-0e5b0846d0214e4c0045ec72ac9b5869e70164bc.tar.bz2
gentoo-0e5b0846d0214e4c0045ec72ac9b5869e70164bc.zip
dev-python/scikit-build-core: add python3_12
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..0e79f26c9258
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ )
+
+ epytest -m "not isolated and not network"
+}