summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-13 07:02:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-13 07:08:34 +0200
commit82ed35e9c35bd1a01bccf24d5b66367f20fab744 (patch)
treee5e4825327c84beadc3ac7cc1f46635cc1d15f4d /dev-python/zeroconf
parentdev-python/zeroconf: Require dev-python/cython < 3 (diff)
downloadgentoo-82ed35e9c35bd1a01bccf24d5b66367f20fab744.tar.gz
gentoo-82ed35e9c35bd1a01bccf24d5b66367f20fab744.tar.bz2
gentoo-82ed35e9c35bd1a01bccf24d5b66367f20fab744.zip
dev-python/zeroconf: Bump to 0.66.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.66.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 8f68b4de80d9..f7887f3e7dae 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -2,3 +2,4 @@ DIST zeroconf-0.62.0.tar.gz 141269 BLAKE2B 17efd98394155e415cc9b9b6ff7b2ec6d7026
DIST zeroconf-0.63.0.tar.gz 141580 BLAKE2B 22267e2be9118c91b5d7638843e89de0a2838eb1ebca2c233038fc202b8648256193fd8d61523960e1fce110ef7e3c3c06190f5369f700c02cbd047a036a362e SHA512 b899838ddae288b0f0483ca6950871d88ee387769507fe803a68df1cd5657bf9eee2aeecfc2e7685ded5327e70e04cfe445b564f16e3e9191112ddaae7deda18
DIST zeroconf-0.64.0.tar.gz 142520 BLAKE2B b26c728519b7962c9620f857654e9bd347b1dcd98642a2305f4102ce8fe76cf2f24a934a7a65c355e1dbeaf2152c31f43b529f922b2c3fceec09dbc3f106c6ff SHA512 b85fab86150e88ab4aec8c5f5d338c962ad071140f5ee472b7f3ba8f196a96976e4dc9c1c99b2bd8040d486d0f79c966d45ee2ba58f7724cdbc3345811b9ebc9
DIST zeroconf-0.64.1.tar.gz 142617 BLAKE2B 100243491aa85b9be8a7664ad9de6f1b202d02fbc2fd3be6116cf1c00c8885ad9fa00c784a036b27338ddb09f6a29b59a056fc610bcf9283cb9fce79110fa07b SHA512 9fa217811bea4b8597bfa4cdca40afd9fdd6920a6499d5b7f61fe78ff09106662f3cbc2381dfbfb541a330ecfa21a751e4bf455f19ba7433b0ebf43da1f21cce
+DIST zeroconf-0.66.0.tar.gz 142962 BLAKE2B 7cc625ea71e00a4e1f47589de1e8168c6299396f1f50d5ba6b530040a0d97ce40b1e858bb76eaaa3e8796c5cc793d819f0b31d693340f2ba5f26cf17d8db3f28 SHA512 544bccaf1acf2a3861c3e0131836f4ccd5d5aadc7222cf34f02ccae61abf32cf7430925698f13d14cf16a62ea9875df6e37fc5e93abfb02dbed79cb1e2e47fe3
diff --git a/dev-python/zeroconf/zeroconf-0.66.0.ebuild b/dev-python/zeroconf/zeroconf-0.66.0.ebuild
new file mode 100644
index 000000000000..50486a2e065a
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.66.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+# Cython-3: https://github.com/python-zeroconf/python-zeroconf/issues/1183
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}