summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-22 05:04:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-22 05:04:19 +0200
commit490ef7f49a206994313e74133cb0250661db2c46 (patch)
treeecdd1a0af30884c73f129efa3deec3781344dbf5 /dev-python/yarl
parentdev-python/yarl: Remove old (diff)
downloadgentoo-490ef7f49a206994313e74133cb0250661db2c46.tar.gz
gentoo-490ef7f49a206994313e74133cb0250661db2c46.tar.bz2
gentoo-490ef7f49a206994313e74133cb0250661db2c46.zip
dev-python/yarl: Bump to 1.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest1
-rw-r--r--dev-python/yarl/yarl-1.16.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index 9117e2278db6..fcbb01975596 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,4 +1,5 @@
DIST yarl-1.13.1.tar.gz 165912 BLAKE2B dfe4f9ac09c66d05b6d072cd6676d1753f97224d556dbd22601e544569d5e852b073c1a89e4ba471177c530ec580fb74700b9e6e21730c548e434ef75933b6bf SHA512 8fccb36dbb019d02fc50f006a3a59decd413abfc6387fd7c1220444f4f79412be1d5119c32fd668b3d553fbaf4de64b9135345e8300c7fa025d892c847955f88
DIST yarl-1.14.0.tar.gz 166127 BLAKE2B 7974896144ef23309aead8935f18fe717e39b982bc75eb3c828eaf9a1d01b413c2bbb270344160a396927fc32571928c67eae46146920cc6908e2e3f74e90cd8 SHA512 8cc9d1aaa6fcccdfce5ea0a0ac3f89b81c5719568b76e66637e9a7baa0637770523f86495f70e28f94f166579e77d72afd708cef1306dafcd8093c7fb2a1d3f0
DIST yarl-1.15.5.tar.gz 172410 BLAKE2B 49d31ed31466921a04d1e83d98c6ec742aaa71a7675da9c9ee4f99ce4ca6813cd471e92e8ee78e4c33c3ea2efe981b8603bf677100b1e9b8f6de3324e2c43074 SHA512 d1219971f5bc90e1d1f4b256a8e90fd98433086cb326f658bd68bfaefd97c12c0ff8121ab16fdd047236f29ce6c3907ea6b0afbde3526fe8ec290dec379ca732
+DIST yarl-1.16.0.tar.gz 176548 BLAKE2B 038934a1ef05c78fd04702ed4519c121b7e9c5e6f41069e179cd7f09c178da9e6a73ab14cf5083dfa0597b24ed351dac0d937f419c58e510c9eb695c3639d2f3 SHA512 ee3933aed6ac0cc5df24cd0e8f3d3d560348b4a7c960562a7bee16e105b6104e24c5720388cd4a1ae20f796f27bf0ce8c599999d554e3cd790c6db27c6799d22
DIST yarl-1.9.4.tar.gz 141869 BLAKE2B 367eac4674bf1190122f10bb1dc1c4f3d5e4263e1d95ff2b871067d55a894dc19a6bb5a6c673d1bed28b3c5f77c704799568edfe639d50f0ae10313eb847352d SHA512 e4f7917f1625b40125abae9a13d61795f97e8cf489735e15cf58476e97c3bcf840b1452482f1f7a737fbb2bdd1dc7bbcfa882d0a7f76a27dfb3aea72b7a66c82
diff --git a/dev-python/yarl/yarl-1.16.0.ebuild b/dev-python/yarl/yarl-1.16.0.ebuild
new file mode 100644
index 000000000000..2f428eea3047
--- /dev/null
+++ b/dev-python/yarl/yarl-1.16.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/propcache-0.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ dev-python/expandvars[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x YARL_NO_EXTENSIONS=0
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ YARL_NO_EXTENSIONS=1
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # benchmarks
+ tests/test_quoting_benchmarks.py
+ tests/test_url_benchmarks.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local opts=()
+ # note different boolean logic than for backend (sigh)
+ local -x YARL_NO_EXTENSIONS=
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ YARL_NO_EXTENSIONS=1
+ fi
+
+ rm -rf yarl || die
+ epytest -o addopts= "${opts[@]}"
+}