summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-26 10:56:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-26 11:37:38 +0100
commit16a877bab22808f4c288732cfe60b8f1cb47ab4c (patch)
tree87f7e4b3c0c3378ec87fce94e7b633282f579e83 /dev-python/xdoctest
parentdev-python/virtualenv: Bump to 20.14.0 (diff)
downloadgentoo-16a877bab22808f4c288732cfe60b8f1cb47ab4c.tar.gz
gentoo-16a877bab22808f4c288732cfe60b8f1cb47ab4c.tar.bz2
gentoo-16a877bab22808f4c288732cfe60b8f1cb47ab4c.zip
dev-python/xdoctest: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.0.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 27abaf468fdc..767b83d77913 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-0.15.10.gh.tar.gz 191579 BLAKE2B 4836b773c3cf664c825433199b13ab7d3fe2c68538517bf5594797ad3f2f894d0132034fdafbc4502a00ec7393c19473fafe15fcf0257e3565592dc9907e3d71 SHA512 18c1a2774ae9331582610e3459a02f4e4de838218e7250af071570b2318f4c14330084b9fb903d88651fc40a4ba12b686ee6f2ca165edd8155e908ae4992a840
+DIST xdoctest-1.0.0.gh.tar.gz 193294 BLAKE2B 95725757faafd2a15652557e07753ad8c4a8ee57b545169ba29b6e8f0ef5c7a021eff3c092cfe123da91311db98ef7700b29d52b1418a8160869402fb4ecfcab SHA512 8c77fbd8fcd1a3030b33651d35567dd4506ece3aa2c6155223d5cdea6e16510b59bcbd5b9ebb6dc13e20af92c5d07dc205485566b836874e835b18a53cbe7355
diff --git a/dev-python/xdoctest/xdoctest-1.0.0.ebuild b/dev-python/xdoctest/xdoctest-1.0.0.ebuild
new file mode 100644
index 000000000000..9ca86944c988
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest/"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx_rtd_theme