summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-08 22:37:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-08 22:58:46 +0100
commit13c468113b6071fa452213e6ae24d67ce33a99e7 (patch)
tree15d26c109dd9fd66718dc49d2a849dc30bb2280c /dev-python/uvicorn
parentdev-python/distlib: Bump to 0.3.4 (diff)
downloadgentoo-13c468113b6071fa452213e6ae24d67ce33a99e7.tar.gz
gentoo-13c468113b6071fa452213e6ae24d67ce33a99e7.tar.bz2
gentoo-13c468113b6071fa452213e6ae24d67ce33a99e7.zip
dev-python/uvicorn: Bump to 0.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.16.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index c43cf7797660..81238cb9b48f 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,2 +1,3 @@
DIST uvicorn-0.14.0.tar.gz 511593 BLAKE2B 9f7aee0001874c128e44d31945aaa0ca92237e594debb6fea3c6c6d0f283c96cfad5248578b0e1c170fe2fde96a6b17c56ecf2436783fcae135b8eab1997b701 SHA512 f41a7f01ac6893ceaf4d1f06a4bccd7355e319eee11d6aa290b0d316fb356eb807c926941157ec64f1fc6b7c4601930cfbe271075d6c4cf684bd7e175617390f
DIST uvicorn-0.15.0_p20210913.gh.tar.gz 542385 BLAKE2B 1e551ffccac6f92981b0ef62cc80fb494b57dc19bddf8430c54b8a06801ee81cdc31a3167a56e90dd8e0f318cc84dfc71443f74beb39dc68ccc252bc6d6c1042 SHA512 865fe148900c8c00847017bab3ef17a9514e7ef7878ad6220633e2bd6d89b2e65a79a82fdabb8beec83841346a175f0c20807bea07536071a06a884c74418e0d
+DIST uvicorn-0.16.0.tar.gz 707858 BLAKE2B 604aa23f8eac6409396ed603c89a524ce61630e3edd354cfe86950c535f3829aa1ececc8a91a8eeb8164d125e2b20add14f457ba0b23a0d0efd085c168739bee SHA512 68eb5daeb72b457a43fa89e352bfe281c79c1057ad9616ba083f96c1392aeb56759f13a3ee7e9eb90749f92df137f1db2bf8c90256751513d770d6679e971003
diff --git a/dev-python/uvicorn/uvicorn-0.16.0.ebuild b/dev-python/uvicorn/uvicorn-0.16.0.ebuild
new file mode 100644
index 000000000000..60bd3936b915
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.16.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="https://www.uvicorn.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ dev-python/watchgod[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+)