summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-07-07 15:23:21 +0200
committerSam James <sam@gentoo.org>2022-07-09 09:15:52 +0100
commit812d96fe75455d45f0e24e3d4f106d48ba047f43 (patch)
tree9b48e2b473a092216df8e7d5bd5e8db2f89e9f05 /dev-python/unpaddedbase64
parentdev-python/pymacaroons: new package, add 0.13.0 (diff)
downloadgentoo-812d96fe75455d45f0e24e3d4f106d48ba047f43.tar.gz
gentoo-812d96fe75455d45f0e24e3d4f106d48ba047f43.tar.bz2
gentoo-812d96fe75455d45f0e24e3d4f106d48ba047f43.zip
dev-python/unpaddedbase64: new package, add 2.1.0
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/unpaddedbase64')
-rw-r--r--dev-python/unpaddedbase64/Manifest1
-rw-r--r--dev-python/unpaddedbase64/metadata.xml16
-rw-r--r--dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild24
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/unpaddedbase64/Manifest b/dev-python/unpaddedbase64/Manifest
new file mode 100644
index 000000000000..660c45753e6a
--- /dev/null
+++ b/dev-python/unpaddedbase64/Manifest
@@ -0,0 +1 @@
+DIST unpaddedbase64-2.1.0.gh.tar.gz 5869 BLAKE2B c53dae277b5e69f6d905724d5b212050100286217fd236f9e1a6c344ff479d4c38ee9634a544b2e693522c04a9bbfdaeebbb2ac79904089d91e4d6c18b6995e8 SHA512 9c7c2dd6e52ffae2bf076ccf9e1e2ea9a53cbef083c23f640cc2f3f5c49ceee0c92c8abe0469e10d80b7c9e74d69b2b06111b1c4204b4cb1788ee3fffcea6e11
diff --git a/dev-python/unpaddedbase64/metadata.xml b/dev-python/unpaddedbase64/metadata.xml
new file mode 100644
index 000000000000..9b1cf451b586
--- /dev/null
+++ b/dev-python/unpaddedbase64/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">unpaddedbase64</remote-id>
+ <remote-id type="github">matrix-org/python-unpaddedbase64</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild b/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
new file mode 100644
index 000000000000..d8e6ae6fb108
--- /dev/null
+++ b/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unpadded Base64"
+HOMEPAGE="
+ https://github.com/matrix-org/python-unpaddedbase64
+ https://pypi.python.org/pypi/unpaddedbase64
+"
+SRC_URI="https://github.com/matrix-org/python-unpaddedbase64/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/python-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest