summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/twython
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/Manifest3
-rw-r--r--dev-python/twython/metadata.xml13
-rw-r--r--dev-python/twython/twython-3.0.0.ebuild22
-rw-r--r--dev-python/twython/twython-3.2.0.ebuild22
-rw-r--r--dev-python/twython/twython-3.3.0.ebuild22
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/twython/Manifest b/dev-python/twython/Manifest
new file mode 100644
index 000000000000..b5780557199b
--- /dev/null
+++ b/dev-python/twython/Manifest
@@ -0,0 +1,3 @@
+DIST twython-3.0.0.tar.gz 28543 SHA256 9ca7148836e9ec298212b946c8bf85776edc5afa7059486560476cb160efe8a3 SHA512 2ecd0954bfc8d442ab9e602ffd8bdb0ca241e7411b51dc3df4285a4ba0691fa6a5f5b4d188461f2248e6135f9e87e7ef973375448946898f3845c2cbde18beee WHIRLPOOL f46eed176cceccd41e7a1aa2c0b671205b9439f67153661430771ba693055707ce6d009ce81453f2c7a1804e65291641e72b29df6c5af7978828c40511c336c7
+DIST twython-3.2.0.tar.gz 33741 SHA256 ab0dec52286677e944ddc00eaf6a0eb89af48b1a6696324ea29351342d1c483f SHA512 809bc9fe3512b383b38e74929dadb4576bc9b51b0ce80ea444aadea44f95f2df0fc119bd0ea1982337e654bd5d92abb78671f20fe3b56e647f6caca00ec3791f WHIRLPOOL 5104295c2610ab76408047875aff2c7cfd49643344804676d7b04eb2e1727b2bfe4d70821505c7f7106744f6fb141adca7f78c19d6d209f3c54a220932a9ada5
+DIST twython-3.3.0.tar.gz 34164 SHA256 afe23e8a718500eb49d2e42375b2c251b58bf13a6f572d9e586fbeaeda18cf37 SHA512 888f37c37f39c603b08605d2e209afc329e079c405adbe3a03fde4dab2b76b07d2badf1956d255d4b7ff0bf2a4c308b20f2a3333a7ccd0e7b9c046e9172b1d5f WHIRLPOOL b1a3a4867bc82a3395e04c6a3a219e7482d585e5139fb5d25fd9eabfec9cc1c8d045d3f984fdb8aefb8d0252e946411bc6f03f196b0f61a682e78ca923f69697
diff --git a/dev-python/twython/metadata.xml b/dev-python/twython/metadata.xml
new file mode 100644
index 000000000000..0de0df0bb21b
--- /dev/null
+++ b/dev-python/twython/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ryanmcgrath/twython</remote-id>
+ <remote-id type="pypi">twython</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/twython/twython-3.0.0.ebuild b/dev-python/twython/twython-3.0.0.ebuild
new file mode 100644
index 000000000000..ca5ae5393224
--- /dev/null
+++ b/dev-python/twython/twython-3.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.3.2[${PYTHON_USEDEP}]"
diff --git a/dev-python/twython/twython-3.2.0.ebuild b/dev-python/twython/twython-3.2.0.ebuild
new file mode 100644
index 000000000000..ed1e81ce54e4
--- /dev/null
+++ b/dev-python/twython/twython-3.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/twython/twython-3.3.0.ebuild b/dev-python/twython/twython-3.3.0.ebuild
new file mode 100644
index 000000000000..d440b0b9bc04
--- /dev/null
+++ b/dev-python/twython/twython-3.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"