summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-11 06:05:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-11 06:20:08 +0200
commit6bc8a844a12f3d57facbd570163c0c29365003ca (patch)
tree8a3f4bc74b19b13c4bae8f4d88a18d60a33c1742 /dev-python/trove-classifiers
parentdev-python/pandas: Bump to 2.2.2{,-r1} (diff)
downloadgentoo-6bc8a844a12f3d57facbd570163c0c29365003ca.tar.gz
gentoo-6bc8a844a12f3d57facbd570163c0c29365003ca.tar.bz2
gentoo-6bc8a844a12f3d57facbd570163c0c29365003ca.zip
dev-python/trove-classifiers: Bump to 2024.4.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index a9642de6fa86..7f4ccd7801e9 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1 +1,2 @@
DIST trove-classifiers-2024.3.25.tar.gz 16040 BLAKE2B 001a307d041e76213f3d2d115a10467b8434afecb0dc268ed9a1943aa7961c9021b49794a593102372c41b6776f3e513db44f680dda700c9897f65ef593ec860 SHA512 3b1d0c08d9a90bfe2314b092270677397d5150f0b641dfaf6ffda7a3447b898ea2c1d2dceab0f61ddceeb6b42945aec19e7a1028bf72ac3a119454f66945db7c
+DIST trove-classifiers-2024.4.10.tar.gz 16036 BLAKE2B bfd0ae5e3e1dc2dab67e66dc9cdf90b3ff789d00fff5f13ddf8974736adf3e37c505488d4aea32b0c4b43a6d77617e9a0672def2e66baf813734b1e3bebb8bd3 SHA512 2705ea82869bb3092dd37c817d5263955249b44ad64c0fcedc523ecc78eaeb2a327500adbafe70c5d08b5961bf8095748e34a0daa1a2ba8db3fa27e1a35a645b
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild
new file mode 100644
index 000000000000..3172a692bdd9
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}