summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-16 21:46:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-16 21:58:05 +0300
commit6b15d75e2c79b3e1b47cd9a6bff733cda9e9cd62 (patch)
tree2eb77169c14b19e32e02bcee687fb58dc6e4df11 /dev-python/texttable
parentdev-python/threadpoolctl: enable py3.11 (diff)
downloadgentoo-6b15d75e2c79b3e1b47cd9a6bff733cda9e9cd62.tar.gz
gentoo-6b15d75e2c79b3e1b47cd9a6bff733cda9e9cd62.tar.bz2
gentoo-6b15d75e2c79b3e1b47cd9a6bff733cda9e9cd62.zip
dev-python/texttable: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/texttable-1.6.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.6.4-r1.ebuild b/dev-python/texttable/texttable-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..34cfa4fab568
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests.py || die
+}
+
+pkg_postinst() {
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}