summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-10 20:17:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-10 20:57:16 +0200
commit8520437bc7ed0a43a6b124323a9c9449a68d5daf (patch)
tree81e6e48690b89af29db56bd84c673bc6c1dca288 /dev-python/testtools
parentdev-python/testtools: Add missing test dep on dev-python/twisted (diff)
downloadgentoo-8520437bc7ed0a43a6b124323a9c9449a68d5daf.tar.gz
gentoo-8520437bc7ed0a43a6b124323a9c9449a68d5daf.tar.bz2
gentoo-8520437bc7ed0a43a6b124323a9c9449a68d5daf.zip
dev-python/testtools: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/testtools-2.7.2.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/testtools/testtools-2.7.2.ebuild b/dev-python/testtools/testtools-2.7.2.ebuild
index 9236369b209a..ff9231e8d803 100644
--- a/dev-python/testtools/testtools-2.7.2.ebuild
+++ b/dev-python/testtools/testtools-2.7.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 pypi
@@ -27,13 +27,20 @@ BDEPEND="
>=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
dev-python/testscenarios[${PYTHON_USEDEP}]
dev-python/testresources[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/twisted[${PYTHON_USEDEP}]
+ ' 3.{10..12})
)
"
distutils_enable_sphinx doc
python_test() {
- "${PYTHON}" -m testtools.run testtools.tests.test_suite ||
+ cp testtools/tests/__init__.py test_suite.py || die
+ if ! has_version "dev-python/twisted[${PYTHON_USEDEP}]"; then
+ sed -i -e '/twistedsupport/d' test_suite.py || die
+ fi
+
+ "${EPYTHON}" -m testtools.run test_suite.test_suite ||
die "tests failed under ${EPYTHON}"
}