summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 11:28:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 11:32:20 +0100
commitc62c1f13ae7cc1bacd9fc5cefbe4fbf5e5e547b6 (patch)
tree44a65eba9e0b9ea1449dfb2462d4a5cf4216f742 /dev-python/sybil
parentnet-im/zoom: drop 5.16.5.303 (diff)
downloadgentoo-c62c1f13ae7cc1bacd9fc5cefbe4fbf5e5e547b6.tar.gz
gentoo-c62c1f13ae7cc1bacd9fc5cefbe4fbf5e5e547b6.tar.bz2
gentoo-c62c1f13ae7cc1bacd9fc5cefbe4fbf5e5e547b6.zip
dev-python/sybil: Bump to 6.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-6.0.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 6be0e9543072..8103cfbfccfe 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,2 +1,3 @@
DIST sybil-5.0.3.gh.tar.gz 56660 BLAKE2B 99af245f765630523ab2c6cb21452a0c3a970109102900530f5528ac0902d0472ceb09778bd266e9071816de1da397480e53220a974c5cc38f40367d552cef5e SHA512 0e2a96457b506558b4e9c58890a370c63dbde2c36780dd031cfe8de828f15a2f790c55df81d86800599302958006e704e627b7e8a5d3dd786398ce5f8ea46d35
DIST sybil-6.0.0.gh.tar.gz 67505 BLAKE2B b7408802d5f6796701603762f1e48dbd2f218b5ae80fad940f1ba1fdf0643d1f16cb0a88d94b6385f6ff47d4ab18463be613f736613fa5f0baa3f9ff056ebfa8 SHA512 a03cb7e874a6a41f41ca21e9110f0b8f0d45bb94a5cd7c4f0eb0528ce01db4ac9ca6d8d84663d8851c01dda5da3cb232bcadb33594c5c10e5775f390db37ee9a
+DIST sybil-6.0.1.gh.tar.gz 67593 BLAKE2B 443881e81da6456f0790929556334513a8e50d54a0053ddb88b07e29e736e9429ea59fdc30b2d7ff7bdf7e1ec9e272864568aa64fb20a52377d0ee0b39ce30aa SHA512 e71f06744ff07f973ac7f131cd58d4df3697b1cf42a5983b9a93b657d9bfc9358084dcdec00de624b5e89ffa518e64d45591bf616fb53f5e4659ff9755893cd9
diff --git a/dev-python/sybil/sybil-6.0.1.ebuild b/dev-python/sybil/sybil-6.0.1.ebuild
new file mode 100644
index 000000000000..38d5f40dd52e
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest