summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-18 03:42:07 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-18 03:42:07 +0100
commit614e42e269e9236f5a75c23533aaaaceb7bdea64 (patch)
tree8cb17dbfa18465569da1a72ed7304fceb362271d /dev-python/sybil
parentdev-python/ipython: Remove old (diff)
downloadgentoo-614e42e269e9236f5a75c23533aaaaceb7bdea64.tar.gz
gentoo-614e42e269e9236f5a75c23533aaaaceb7bdea64.tar.bz2
gentoo-614e42e269e9236f5a75c23533aaaaceb7bdea64.zip
dev-python/sybil: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/files/sybil-6.0.2-pytest-8.patch40
-rw-r--r--dev-python/sybil/sybil-6.0.2-r1.ebuild44
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 8ccec810aac4..6334c9906f97 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,2 +1 @@
-DIST sybil-6.0.2.gh.tar.gz 67619 BLAKE2B ec723cb21d2ac1232bd6e9a3e3edb0bc65c705048c2d288df778b4dd19a1b46c956f7d2bd57dfa028d7a8a06357501ffc1226ba171e2073abec51f8d3c536d86 SHA512 9966173b5fb013be1f298b586052d8c10b76efb43bf5230f3d0b780e6d6238e7e33840eeb7c8b9860911351ea612766ed19ea2a61d48424465f3b58e408da5d2
DIST sybil-6.0.3.gh.tar.gz 67772 BLAKE2B e90b7a01373d931ca056bfce1336bab8a579a25e17000675d77cd849081275970b455c7bc77f30e0fd104073115915fc4f4477b010eafd35e57aec322fb42fc4 SHA512 1fb42b944b237556012ace6fcc5eb3d0f067f0ca043ceafa0e201a8076870fc7e06ae62813eec90d486de6e4b71ebf29176dfff6573de423480c688ff005004d
diff --git a/dev-python/sybil/files/sybil-6.0.2-pytest-8.patch b/dev-python/sybil/files/sybil-6.0.2-pytest-8.patch
deleted file mode 100644
index 2447289c0266..000000000000
--- a/dev-python/sybil/files/sybil-6.0.2-pytest-8.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From d7428b4cfe5f817037030d025028bf09fd7992ee Mon Sep 17 00:00:00 2001
-From: Adam Dangoor <adamdangoor@gmail.com>
-Date: Mon, 29 Jan 2024 11:29:16 +0000
-Subject: [PATCH] Add fixes for Pytest 8.0.0
-
----
- CHANGELOG.rst | 5 +++++
- sybil/integration/pytest.py | 17 +++++++++++++----
- 2 files changed, 18 insertions(+), 4 deletions(-)
-
-diff --git a/sybil/integration/pytest.py b/sybil/integration/pytest.py
-index 8ce6c72..cad311d 100644
---- a/sybil/integration/pytest.py
-+++ b/sybil/integration/pytest.py
-@@ -53,12 +53,21 @@ def __init__(self, parent, sybil, example: Example) -> None:
- def request_fixtures(self, names):
- # pytest fixtures dance:
- fm = self.session._fixturemanager
-- closure = fm.getfixtureclosure(names, self)
-- initialnames, names_closure, arg2fixturedefs = closure
-- fixtureinfo = FuncFixtureInfo(names, initialnames, names_closure, arg2fixturedefs)
-+ if PYTEST_VERSION >= (8, 0, 0):
-+ closure = fm.getfixtureclosure(initialnames=names, parentnode=self, ignore_args=set())
-+ names_closure, arg2fixturedefs = closure
-+ fixtureinfo = FuncFixtureInfo(argnames=names, initialnames=names, names_closure=names_closure, name2fixturedefs=arg2fixturedefs)
-+ else:
-+ closure = fm.getfixtureclosure(names, self)
-+ initialnames, names_closure, arg2fixturedefs = closure
-+ fixtureinfo = FuncFixtureInfo(names, initialnames, names_closure, arg2fixturedefs)
- self._fixtureinfo = fixtureinfo
- self.funcargs = {}
-- self._request = fixtures.FixtureRequest(self, _ispytest=True)
-+ if PYTEST_VERSION >= (8, 0, 0):
-+ self._request = fixtures.TopRequest(pyfuncitem=self, _ispytest=True)
-+ self.fixturenames = names_closure
-+ else:
-+ self._request = fixtures.FixtureRequest(self, _ispytest=True)
-
- def reportinfo(self) -> Tuple[Union["os.PathLike[str]", str], Optional[int], str]:
- info = '%s line=%i column=%i' % (
diff --git a/dev-python/sybil/sybil-6.0.2-r1.ebuild b/dev-python/sybil/sybil-6.0.2-r1.ebuild
deleted file mode 100644
index 0a280c114202..000000000000
--- a/dev-python/sybil/sybil-6.0.2-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automated testing for the examples in your documentation"
-HOMEPAGE="
- https://github.com/simplistix/sybil/
- https://pypi.org/project/sybil/
-"
-# tests are missing in sdist, as of 5.0.1
-SRC_URI="
- https://github.com/simplistix/sybil/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-BDEPEND="
- test? (
- dev-python/myst-parser[${PYTHON_USEDEP}]
- dev-python/seedir[${PYTHON_USEDEP}]
- dev-python/testfixtures[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/simplistix/sybil/pull/108
- "${FILESDIR}/${P}-pytest-8.patch"
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}