summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 15:56:32 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 17:02:30 +0200
commit17312c0282ab88880cfc6badd83a507f51b0861a (patch)
treeb7da01015ffbd8237be49a416a912c91ac1d6711 /dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
parentnet-dialup/rp-pppoe: Added missing rdep on sys-apps/iproute2 (diff)
downloadgentoo-17312c0282ab88880cfc6badd83a507f51b0861a.tar.gz
gentoo-17312c0282ab88880cfc6badd83a507f51b0861a.tar.bz2
gentoo-17312c0282ab88880cfc6badd83a507f51b0861a.zip
dev-python/stdio-mgr: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild')
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
new file mode 100644
index 000000000000..4c032aa553ed
--- /dev/null
+++ b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
+HOMEPAGE="
+ https://github.com/bskinn/stdio-mgr/
+ https://pypi.org/project/stdio-mgr/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND=">=dev-python/attrs-17.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+# doc directory is not included in the release tarball for some reason
+#distutils_enable_sphinx doc \
+# dev-python/sphinxcontrib-programoutput \
+# dev-python/sphinx_rtd_theme
+
+python_test() {
+ # skip the doctests
+ epytest tests
+}