summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNowa Ammerlaan <nowa@gentoo.org>2025-01-23 19:52:34 +0100
committerNowa Ammerlaan <nowa@gentoo.org>2025-01-23 19:52:34 +0100
commite5a47852b7e9a13f7e9514d7aaaa36bc55e83421 (patch)
tree60e409ece4ed853558553fe6f7679d7371713d94 /dev-python/spyder-notebook
parentdev-python/spyder-line-profiler: drop 0.3.2 (diff)
downloadgentoo-e5a47852b7e9a13f7e9514d7aaaa36bc55e83421.tar.gz
gentoo-e5a47852b7e9a13f7e9514d7aaaa36bc55e83421.tar.bz2
gentoo-e5a47852b7e9a13f7e9514d7aaaa36bc55e83421.zip
dev-python/spyder-notebook: drop 0.5.1
Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest1
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
index 12e21c7932ba..fdfeac6f691a 100644
--- a/dev-python/spyder-notebook/Manifest
+++ b/dev-python/spyder-notebook/Manifest
@@ -1,2 +1 @@
-DIST spyder-notebook-0.5.1.tar.gz 5546854 BLAKE2B ccdc93c948e6b4db005cf2433794008c65e9a56574db15cd5627f44938bcc2c865341f2417bcf000e27e3d19fe11b6eb6340e6225a682bf32b2cb06ca8f4605a SHA512 daf91361344f96db0ac855b80d17388bda7bf96eab280fba7ac406915dc9b5283c09e914c07342154ed2d0d23420b5e16923cf4ccddb090364db43cf606319f3
DIST spyder_notebook-0.6.1.tar.gz 7118143 BLAKE2B d1893d96f91fb192eba13342edf67089ffa664b152b7777f3e626f8541ea2a2b7a20f1b73d72b55c2107abe02870cb63ee17b535dd13a3db882971b8c11eac33 SHA512 2bb7e4d1c4255cfb385e80bb46b3de7ae6c7fd4d4cdc27188cd530699cbc4654d2ace6e8341bc47b029d3e757dd860e2b0a65c2f00a91ae589032de86330cd84
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild
deleted file mode 100644
index acc0e9b663b3..000000000000
--- a/dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-
-inherit distutils-r1 pypi virtualx
-
-DESCRIPTION="Jupyter notebook integration with Spyder"
-HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- dev-python/nbformat[${PYTHON_USEDEP}]
- >=dev-python/notebook-7[${PYTHON_USEDEP}]
- <dev-python/notebook-8[${PYTHON_USEDEP}]
- dev-python/qdarkstyle[${PYTHON_USEDEP}]
- dev-python/qtpy[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/spyder-5.4.3[${PYTHON_USEDEP}]
- <dev-python/spyder-6[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( "README.md" "CHANGELOG.md" )
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Hangs
- spyder_notebook/widgets/tests/test_main_widget.py::test_save_notebook
- spyder_notebook/widgets/tests/test_main_widget.py::test_new_notebook
- # Fails in sandbox
- spyder_notebook/tests/test_plugin.py::test_open_console_when_no_kernel
- spyder_notebook/widgets/tests/test_main_widget.py::test_shutdown_notebook_kernel
- spyder_notebook/widgets/tests/test_main_widget.py::test_file_in_temp_dir_deleted_after_notebook_closed
- # Some missing file
- spyder_notebook/widgets/tests/test_main_widget.py::test_open_notebook_in_non_ascii_dir
- spyder_notebook/widgets/tests/test_main_widget.py::test_close_nonexisting_notebook
-)
-
-python_test() {
- virtx epytest
-}