summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zachary.medico@sony.com>2019-06-27 12:33:44 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-27 12:43:58 -0700
commit8093917d933b85a4726a601ed7f2e0f99ba9403c (patch)
tree33c6c3c6850bb4248ffcad94ef24780dd2bc8f22 /dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild
parentdev-libs/cudnn: correct manifest checksum (diff)
downloadgentoo-8093917d933b85a4726a601ed7f2e0f99ba9403c.tar.gz
gentoo-8093917d933b85a4726a601ed7f2e0f99ba9403c.tar.bz2
gentoo-8093917d933b85a4726a601ed7f2e0f99ba9403c.zip
dev-python/sphinx_celery: require sphinx-2.0.0
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild')
-rw-r--r--dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild b/dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..4fb97cf5c686
--- /dev/null
+++ b/dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Celery Sphinx Theme and Utilities"
+HOMEPAGE="https://pypi.org/project/sphinx_celery/ https://github.com/celery/sphinx_celery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"