summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-23 21:24:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-23 22:06:37 +0200
commit5c702866e128a39f79aea15bf22e33fdb63079d6 (patch)
tree16944e96d47354b5e13fdcf6819077f5cd50fd29 /dev-python/sphinx-autoapi
parentdev-python/pytools: Bump to 2024.1.11 (diff)
downloadgentoo-5c702866e128a39f79aea15bf22e33fdb63079d6.tar.gz
gentoo-5c702866e128a39f79aea15bf22e33fdb63079d6.tar.bz2
gentoo-5c702866e128a39f79aea15bf22e33fdb63079d6.zip
dev-python/sphinx-autoapi: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest1
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.2.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index e7d25ff332d2..ccf1a9ebc0c0 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-autoapi-3.1.2.gh.tar.gz 68260 BLAKE2B 31315fb298f7dae78c10f839e2738340eaf68d5497f22368c50f14309a564d1c5636015a715a9f99080a4f753416a10c63147e63dfcd53a27d7466ad422f95c4 SHA512 18e4a49e831446fa14278ffda4fec703f3b2c86654ce78fa7f4b89e5a41f1e6b19ea76cb64e7290a3125dc027a2de8aa052495a8bfd4bcc1828780f762e81957
DIST sphinx-autoapi-3.2.0.gh.tar.gz 68693 BLAKE2B f9d70febea444a12c4db906614223415f51e649c3cb02770ca24e7274cb1e6c64a86802545ff1cb7b22e0e63bb63ceaaf1c27e487982a3d8d45e750a497dda01 SHA512 d14d62d4ab414f54f0066a63de490c293fbbbb1ca364b3094ca915fcb7765f373650a933026bf9582aeafb5556efb83c72a907f17c5168888bcfd7cbad081583
+DIST sphinx-autoapi-3.2.1.gh.tar.gz 68891 BLAKE2B b31db0f584498a96d3bf7e57fa92abd884d3b8bb8812236a8491685f0fc81d212e114ae1663e316ba7ba14dee082dd4aeab19941f3d6ab85de95399f3736f596 SHA512 e1920a79ce8954a9da1d33fd46e5c1968990e5cfd960a8c97ac344d3d6dd97c06dbbafb3144e67d223f6504b233e0cf59328f015d918264df12b00aed8e34f8f
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.2.1.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.2.1.ebuild
new file mode 100644
index 000000000000..2dfb0a4c4c8b
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}