summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-10 08:33:19 +0000
committerSam James <sam@gentoo.org>2023-03-10 08:40:04 +0000
commit2dcbafe2ff75d8ec939beee520a7a7e130714240 (patch)
tree73477c8184255bc4b1a5c0bb985cf8c22697077b /dev-python/sip
parentnet-nds/389-ds-base: fix build w/ newer dev-python/packaging (diff)
downloadgentoo-2dcbafe2ff75d8ec939beee520a7a7e130714240.tar.gz
gentoo-2dcbafe2ff75d8ec939beee520a7a7e130714240.tar.bz2
gentoo-2dcbafe2ff75d8ec939beee520a7a7e130714240.zip
dev-python/sip: add 6.7.7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-6.7.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index f33cd69f4a37..cc216d27b17e 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,2 +1,3 @@
DIST sip-4.19.25.tar.gz 1056384 BLAKE2B f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98 SHA512 60fb4133c68869bf0993144978b4847d94a0f9c7b477f64a346ea133cfe35bc11820204ab327dcf9a929b6f65a26d16cc7efbce65e49967c3347b39376e57001
DIST sip-6.7.5.tar.gz 1160691 BLAKE2B 64572687e026854c3e8ba7de637925f13a880e51e574993e37190b9b1fafa1850da686600a652bab9d399f58516e2c4e4d8a93f5fb13d53a12ecc5ec3885a98c SHA512 2dc38a6c0489e374a016b7db1f9443bb5d2fb29dc1fa7647ed2dd5bb4aa8758586e2b85569f9fb3b992e15eded0f7a783ec1a53b3d18bee3f8be53d43b79b7b9
+DIST sip-6.7.7.tar.gz 1161807 BLAKE2B b9a49e2d86f3b13b5852b91403946920c25e9b7c3cb3129f6beece1ba6d607493a04fb0d5c0dd564fbe4b7e814ad9837daf6331096b7a1a4a24ff2a7bb11acb4 SHA512 b41a1e53e8bad1fca08eda2c89b8a7cabe6cb9e54d0ddeba0c718499b0288633fb6b90128d54f3df2420e20bb217d3df224750d30e865487d2b0a640fba82444
diff --git a/dev-python/sip/sip-6.7.7.ebuild b/dev-python/sip/sip-6.7.7.ebuild
new file mode 100644
index 000000000000..c095c159f852
--- /dev/null
+++ b/dev-python/sip/sip-6.7.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="
+ https://www.riverbankcomputing.com/software/sip/
+ https://pypi.org/project/sip/
+"
+
+if [[ ${PV} == *_pre* ]]; then
+ MY_P=${PN}-${PV/_pre/.dev}
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit pypi
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+
+distutils_enable_sphinx doc --no-autodoc
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.7.5-tomli.patch
+)