summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/simples3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/simples3')
-rw-r--r--dev-python/simples3/Manifest1
-rw-r--r--dev-python/simples3/metadata.xml14
-rw-r--r--dev-python/simples3/simples3-1.0.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/simples3/Manifest b/dev-python/simples3/Manifest
new file mode 100644
index 000000000000..4d927e6e880b
--- /dev/null
+++ b/dev-python/simples3/Manifest
@@ -0,0 +1 @@
+DIST simples3-1.0.tar.gz 14630 SHA256 2f3d3ef5a691741a489971e292cca2fd69bb11937b542bd1838793da2014f0fc SHA512 3f715eb9dc7cae22f0d08e01599d15e33f5f52441d17a85b6017c15bdfeb125d473ef0d0f19de712f7d09d4127f71e423adc6aaeec461c32fd7568e9ed4c7e54 WHIRLPOOL f0a32d367cf3fc208d0cd6b6254c6bba96dcf8d3ec90350595f468d4254429b3c30949643ab0d17ad9d60e80e01a1f0c956deb42d74ea59fe8e7b13a7fb52000
diff --git a/dev-python/simples3/metadata.xml b/dev-python/simples3/metadata.xml
new file mode 100644
index 000000000000..f98bb7f53d6c
--- /dev/null
+++ b/dev-python/simples3/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Proxy-Maintainer, assign bugs</description>
+ </maintainer>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">simples3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simples3/simples3-1.0.ebuild b/dev-python/simples3/simples3-1.0.ebuild
new file mode 100644
index 000000000000..e0dc24084c65
--- /dev/null
+++ b/dev-python/simples3/simples3-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A fairly simple, decently quick python interface to Amazon's S3 storage service"
+HOMEPAGE="http://sendapatch.se/projects/simples3/ http://pypi.python.org/pypi/simples3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( changes.rst README TODO )
+
+python_prepare_all() {
+ sed -i -e "s/setuptools/distutils.core/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}