summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-26 19:50:08 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-26 19:50:08 +0300
commit6ad398444b32dc93bfd70da74302255a8675c280 (patch)
tree542d86025af3ecb5753e8b8c6fa83c1ccb6d3d56 /dev-python/serpent
parentdev-python/nptyping: add 2.2.0 (diff)
downloadgentoo-6ad398444b32dc93bfd70da74302255a8675c280.tar.gz
gentoo-6ad398444b32dc93bfd70da74302255a8675c280.tar.bz2
gentoo-6ad398444b32dc93bfd70da74302255a8675c280.zip
dev-python/serpent: add 1.41
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/serpent')
-rw-r--r--dev-python/serpent/Manifest1
-rw-r--r--dev-python/serpent/serpent-1.41.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/serpent/Manifest b/dev-python/serpent/Manifest
index 9d28412f5913..73d69bb892cd 100644
--- a/dev-python/serpent/Manifest
+++ b/dev-python/serpent/Manifest
@@ -1 +1,2 @@
DIST serpent-1.40.tar.gz 24140 BLAKE2B 8a790e3f0973e99840cbea6ad354012cde0b7c6ee09c50f31d56110e12cf848543a30a38900e821419c9a0aaeb2b55fe0161dbc9c233f236a21dc553cefce9e6 SHA512 9f8edebcd6e37de7442a00157f64b1dec6742cd198f45ab475be7f38aff4e090345739f7500181f0b0a4dbdc9241b2f11bca5ada7a89aa577d94646269d7ab28
+DIST serpent-1.41.tar.gz 88927 BLAKE2B 738c0e3ff3ff908514a54523aa41bcda3aa4426d0426037a0223ddb744995bf9175de96df2372506aaf45de664897e35cd7292b9aa58beab146f225ce02864f1 SHA512 cab6f9e36d2f777e58cd5f3d1dd6e11626e0f222ecb2adb8e5997338c76ed357c461dadd00010cfd43ffc6a0b1addd7de06d86b7a82ca796719e4bde2d9f4813
diff --git a/dev-python/serpent/serpent-1.41.ebuild b/dev-python/serpent/serpent-1.41.ebuild
new file mode 100644
index 000000000000..9c183aa8a170
--- /dev/null
+++ b/dev-python/serpent/serpent-1.41.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.org/project/serpent/
+ https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests
+}