summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmertt3@gmail.com>2020-05-05 15:35:19 -0500
committerSam James <sam@gentoo.org>2020-08-05 05:43:11 +0000
commit168f3bc06dbfbf4f06b39a5707cf2b78b9b32296 (patch)
tree78beb2f57f15dafe201aa9d3cb1ec4cf9dd40f66 /dev-python/requests-cache
parentnet-mail/dovecot: remove old (diff)
downloadgentoo-168f3bc06dbfbf4f06b39a5707cf2b78b9b32296.tar.gz
gentoo-168f3bc06dbfbf4f06b39a5707cf2b78b9b32296.tar.bz2
gentoo-168f3bc06dbfbf4f06b39a5707cf2b78b9b32296.zip
dev-python/requests-cache: Add 0.5.2
Signed-off-by: John Helmert III <jchelmert3@posteo.net> Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://github.com/gentoo/gentoo/pull/15661 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-0.5.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 06a5f924bc0e..fa46d4c925e8 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1 +1,2 @@
DIST requests-cache-0.4.12.zip 44767 BLAKE2B f328d8ae8e3377af626030a6e3617c78e488024fa4ada9894576d339e571ba8ee6d905612ddc2802810bbeffbd8c94d90c743889e80fbf21418a7c67c5a005f6 SHA512 784d630eec99b607596d6ebcb7e51b0b4ed612b131437000391ecea6f3a684d1f61d169d57266ffc044a3939dcd4e7d6f85b9538165ae3613b1d3e55f18585fd
+DIST requests-cache-0.5.2.tar.gz 31159 BLAKE2B 4fca146a751064baf70954a71df64dbb7f8c9a4e27fec5dbea3620496ce78e7ccfb3785fb63705f513ff6fa938376b0c6acc4a2f584856060b1bc8388517df46 SHA512 355cc571a46b768615606a907a69ed065b3c4b5e74bb6c311abc7a28d9406f32fdea1db0dfd2b1c32dcdc82ed817ef7e0b30086c069de57307254617604c5177
diff --git a/dev-python/requests-cache/requests-cache-0.5.2.ebuild b/dev-python/requests-cache/requests-cache-0.5.2.ebuild
new file mode 100644
index 000000000000..ac500f4f68b1
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.5.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="https://pypi.org/project/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # Ships with incorrect mock import
+ sed -e 's/import mock/import unittest.mock as mock/' -i tests/test_cache.py || die
+ default
+}
+
+python_test() {
+ local skipped_tests=(
+ # Slew of tests that violate network-sandbox
+ tests/test_cache.py::CacheTestCase::test_attr_from_cache_in_hook
+ tests/test_cache.py::CacheTestCase::test_cache_unpickle_errors
+ tests/test_cache.py::CacheTestCase::test_close_response
+ tests/test_cache.py::CacheTestCase::test_content_and_cookies
+ tests/test_cache.py::CacheTestCase::test_delete_urls
+ tests/test_cache.py::CacheTestCase::test_disabled
+ tests/test_cache.py::CacheTestCase::test_enabled
+ tests/test_cache.py::CacheTestCase::test_expire_cache
+ tests/test_cache.py::CacheTestCase::test_from_cache_attribute
+ tests/test_cache.py::CacheTestCase::test_get_parameters_normalization
+ tests/test_cache.py::CacheTestCase::test_get_params_as_argument
+ tests/test_cache.py::CacheTestCase::test_gzip_response
+ tests/test_cache.py::CacheTestCase::test_headers_in_get_query
+ tests/test_cache.py::CacheTestCase::test_hooks
+ tests/test_cache.py::CacheTestCase::test_https_support
+ tests/test_cache.py::CacheTestCase::test_ignore_parameters_get
+ tests/test_cache.py::CacheTestCase::test_ignore_parameters_post
+ tests/test_cache.py::CacheTestCase::test_ignore_parameters_post_json
+ tests/test_cache.py::CacheTestCase::test_ignore_parameters_post_raw
+ tests/test_cache.py::CacheTestCase::test_post
+ tests/test_cache.py::CacheTestCase::test_post_data
+ tests/test_cache.py::CacheTestCase::test_post_parameters_normalization
+ tests/test_cache.py::CacheTestCase::test_post_params
+ tests/test_cache.py::CacheTestCase::test_remove_expired_entries
+ tests/test_cache.py::CacheTestCase::test_response_history
+ tests/test_cache.py::CacheTestCase::test_response_history_simple
+ tests/test_cache.py::CacheTestCase::test_return_old_data_on_error
+ tests/test_cache.py::CacheTestCase::test_stream_requests_support
+ tests/test_monkey_patch.py::MonkeyPatchTestCase::test_requests_from_cache
+
+ # This throws many errors with network-sandbox, but doesn't fail the
+ # build
+ tests/test_thread_safety::test_thread_safety
+ )
+
+ pytest -vv --ignore tests/test_redistdict.py ${skipped_tests[@]/#/--deselect } || die "Tests fail with ${EPYTHON}"
+}