summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-18 17:53:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-18 17:53:16 +0100
commit29be3e4aca5b19861b506ece41df7679aadde496 (patch)
treea7e067467766e6bb212066d2cc2ac5b638785c3e /dev-python/random2
parentdev-python/progressbar2: Bump to 4.3.2 (diff)
downloadgentoo-29be3e4aca5b19861b506ece41df7679aadde496.tar.gz
gentoo-29be3e4aca5b19861b506ece41df7679aadde496.tar.bz2
gentoo-29be3e4aca5b19861b506ece41df7679aadde496.zip
dev-python/random2: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/random2')
-rw-r--r--dev-python/random2/Manifest1
-rw-r--r--dev-python/random2/random2-1.0.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/random2/Manifest b/dev-python/random2/Manifest
index 593715f790fc..14812d782274 100644
--- a/dev-python/random2/Manifest
+++ b/dev-python/random2/Manifest
@@ -1 +1,2 @@
DIST random2-1.0.1.zip 21088 BLAKE2B 69747711e355d3dea2b16562a6b9cdaa170732172e9eaac9a5cee4b8058f569e0c4527aec89e408e6472168fdecfc52b87703d23f153ec04f6ed2c049bcd162a SHA512 31de31c27bc6e07e99c24d30e97d9ddc3085fe557bcb0725881d4ab0b4c06e6208f64ba6267098c7b1be4f115ad45b399e841beecc90f71da2fb7d82982e75ff
+DIST random2-1.0.2.tar.gz 18095 BLAKE2B 17755408300a40c792fd1e6fdef278666408b178016b7b0d0c7b7e7a4927c522bea70961ae0393d3be35fcce8a6924a0421fe7e7fc319ff831d3346712060a07 SHA512 69b91de23ae2f384bf0054bd8e2bf36de0778b006d7c4620dd34b86297f021f80670c550069086f3c123cc47126e41449323de4944a31754c9d830eb08ab7db0
diff --git a/dev-python/random2/random2-1.0.2.ebuild b/dev-python/random2/random2-1.0.2.ebuild
new file mode 100644
index 000000000000..5ed0932fe142
--- /dev/null
+++ b/dev-python/random2/random2-1.0.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python 2.7 random module ported to Python 3"
+HOMEPAGE="https://pypi.org/project/random2/"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+python_test() {
+ "${EPYTHON}" -m unittest -vv src.tests.test_suite ||
+ die "Tests failed with ${EPYTHON}"
+}