summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-12-23 01:08:28 +0100
committerDavide Pesavento <pesa@gentoo.org>2019-12-23 01:08:28 +0100
commitd63893e5f11f7cb01867e12e35b00e6901b58932 (patch)
tree797a3e84a61ae51b1cfe28dde6c7b17745dd38ee /dev-python/qscintilla-python
parentsys-devel/crossdev: set HOMEPAGE to Project:Crossdev (diff)
downloadgentoo-d63893e5f11f7cb01867e12e35b00e6901b58932.tar.gz
gentoo-d63893e5f11f7cb01867e12e35b00e6901b58932.tar.bz2
gentoo-d63893e5f11f7cb01867e12e35b00e6901b58932.zip
dev-python/qscintilla-python: drop 2.11.1-r1
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/Manifest1
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.11.1-r1.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index c9fd8e685d59..afe4c275980f 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,3 +1,2 @@
DIST QScintilla-2.11.3.tar.gz 3006383 BLAKE2B 6238aaff44d6136a64e8c38e38c4886357eb72aa4067f54eda1e876040c41ebce8577e244b81a062e9020c4d142439f5612ca88055d0ba87172ff5b8893938d7 SHA512 83406ef2f425c6288fcac52b01417853186ba860e33e14b236801271e034c327cbb00817cb7247e98bafc1844aeff9f24ec4878ac8ec4bd52d0d2d9778f6b884
DIST QScintilla_gpl-2.10.8.tar.gz 2736054 BLAKE2B 4bc7a2bc1974f8e10a96b7716a8e35d4854e9eeb8040734f99b796bddd9679ee2539f6517743689f9d7deff9ce523cdbb2f77ccd65eaadfc947dcc7a1337d918 SHA512 c0a216737dbda6bc390225196b37a43e4884c9cd67e6e81fc1b1b952683fe88dbfe7caf3c66d94a378f37502e1f08cbdf788426248e73f5f66ec65982b7652b5
-DIST QScintilla_gpl-2.11.1.tar.gz 2932060 BLAKE2B 9f2f9fd89667cc04c95d0a36e4a615dcf3c1c11a5446e19a43104513894b76bc7478f2aed7e8c94ce413f940327deb09e51507bee1fa35c79c176e01e6b74767 SHA512 40b600aa8eec17bc99491a08aeaee72bf498a66f0257d310a8df2667de82805715b9c859885c092acfb03ba8f69433a6517d0d4bb324bf99bd9db461172c08d5
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.11.1-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.11.1-r1.ebuild
deleted file mode 100644
index e5efd8e7353c..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.11.1-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
-inherit python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for QScintilla"
-HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
-
-MY_PN=QScintilla
-MY_P=${MY_PN}_gpl-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="debug"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/PyQt5-5.12[gui,printsupport,widgets,${PYTHON_USEDEP}]
- >=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- ~x11-libs/qscintilla-${PV}:=
-"
-DEPEND="${RDEPEND}
- >=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
-"
-
-S=${WORKDIR}/${MY_P}/Python
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --pyqt=PyQt5
- --qmake="$(qt5_get_bindir)"/qmake
- $(usex debug '--debug --trace' '')
- --verbose
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- # Fix parallel install failure
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets' ${MY_PN}.pro || die
-
- # Run eqmake to respect toolchain and build flags
- eqmake5 -recursive ${MY_PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake INSTALL_ROOT="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-}