summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-27 21:08:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-27 21:09:39 +0200
commitc90a5b6a2eb06c1846615e075f89c0be7f8b3461 (patch)
tree47395f31be162c787ee3e3f488e87804b1863178 /dev-python/pythran
parentdev-python/pybind11: Enable py3.13 (diff)
downloadgentoo-c90a5b6a2eb06c1846615e075f89c0be7f8b3461.tar.gz
gentoo-c90a5b6a2eb06c1846615e075f89c0be7f8b3461.tar.bz2
gentoo-c90a5b6a2eb06c1846615e075f89c0be7f8b3461.zip
dev-python/pythran: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/pythran-0.16.1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/pythran/pythran-0.16.1.ebuild b/dev-python/pythran/pythran-0.16.1.ebuild
index fe9595e00b3b..2e6579a35281 100644
--- a/dev-python/pythran/pythran-0.16.1.ebuild
+++ b/dev-python/pythran/pythran-0.16.1.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( pypy3 python3_{10..12} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1
@@ -44,10 +43,10 @@ BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
+ ' 3.{10..12})
+ dev-python/pip[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
virtual/cblas
!!dev-python/setuptools-declarative-requirements
@@ -97,6 +96,12 @@ python_test() {
pythran/tests/test_set.py::TestSet::test_fct_symmetric_difference_update
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # repr() differences?
+ pythran/tests/test_xdoc.py::TestDoctest::test_tutorial
+ pythran/tests/test_xdoc.py::TestDoctest::test_utils
+ )
esac
fi